Following the Integration Tutorial and Encountering Issues ::Help::

Unity Ver.2020.3.181f1 LTS
FMOD Ver.2.02.03

I don’t know if it’s something basic, but I have been trying to follow the tutorial, being pretty exact really, and I am already stuck… I built my saved version of the example project and tried to bring it into Unity and I cannot access Events, or any of the folders for that matter, and the status in the image below appears when I build Example.fspro again. I have not done anything outside what is listed in the Tutorial and I have tried following it through from start to finish a number of times and every time it’s the same issue. Any idea of what I should be doing differently? Because this is pretty frustrating already…

Sorry, didn’t realise the image would upload so small… Anyway, here’s the prompt.

I can’t see the screenshot very well, but it looks like the project is in Sound/Examples/Examples.fspro but it’s looking for builds in Sound/Examples/Build. Can you confirm these directories are correct? Also the Unity integration does not work with custom build directories, so could you please ensure you aren’t building to a different directory by looking in Edit > Preferences > Build in the FMOD Studio project?

I’m not sure I get what you mean, I have been following the tutorial exactly, so I have not changed any settings, including the build directory. These are of what FMod is automatically doing when I follow the tutorial, if the directories or settings are incorrect or I need to be doing extra set up, it would be good if it was listed in the tutorial itself, as I have never used this software before and I am unsure how I am supposed to know how to do things differently.


That is very strange. Are you able to confirm some following things:

  • Please delete all banks in E:\Sound\Examples\Build\Desktop and rebuild them in FMOD Studio
  • Please confirm that the version of FMOD Studio and the FMOD Unity integration are the same
  • Please confirm that is not read-only and that they are not in any cloud backup programs such as Google Drive or Dropbox

I got it to work. It was a version issue; you should really update the Unity Store page, because that’s where I found out about this and the latest version (2.01) on there is incompatible with the latest version of FMod.