Inconsistent fade envelopes

Why do fade envelopes like these produce inconsistent playback each time I click Play in the Studio app? Is there anything that can be done to fix this? I’m using FMOD 2.02.02, Windows 10.

image

1 Like

When I test here, playback of synchronous single instruments with fade-in curves appears to be consistent from one playback to the next.

Is there any more information you can give us about this issue? For example, exactly how does the instrument’s behavior change from one playback to the next? Are any of the instrument’s properties subject to modulation or automation? What is the instrument’s start offset property set to?

I also always noticed some inconsistencies on the transients at the very beginning after a transition. I first thought if was related to transitions, but as Shredd spotted, it’s probably rather related to the fades I include in the transition timeline.
I just investigated further and it’s quite easy to spot. Here it is: a really short sound, a really short fade in the transition timeline. The sound is never the same, or even don’t play at all.
I should have displayed time rather than beats. For info, the fade is 30 ms duration and the sound 14 ms.

1 Like

Or even with a fade directly on the instrument, that’s obvious too:

1 Like

I think @Alcibiade already nailed it with their videos, thanks! Here’s mine with a kick drum:

So essentially, I think the fade-in length keeps changing randomly. And sometimes it sounds like the very first milliseconds of the transient are let through, too, as if the fade-in curve wasn’t there. Just to be clear, this happens the same way whether I click Play manually every time, or loop it.

I was not using modulation or start offset in this example, nor my earlier screenshot. Just dragged and dropped the sample in and disabled the spatializer.

This is most easily heard when using very short sounds, but it happens regularly with any length of audio clip.

What audio hardware are you using @joseph? I shot the video while I was using just WASAPI drivers, but I tested with my audio interface’s ASIO drivers (SSL+2), and it was the same.

1 Like

All fades and automation in FMOD are basically quantized to the frame rate. If the fades are very short it’s mostly a matter where the steps occur. You can hear the steppiness very clearly if you try fading a pure sine wave tone in and out.

If you increase FMOD’s internal frame rate from the API you get smoother fades and automation but it increases the performance cost.

AFAIK sample-accurate fades and automation are in the FMOD development backlog but these would come at a performance cost as well.

1 Like

Interesting. But frame rate of what, exactly? The FMOD Studio app itself?

The FMOD developers will need to answer that one. Update length steps, mixing blocks, not sure what the exact rate is.

Older thread:

1 Like

Can you describe how you get the playback to be consistent on your end? And what frame rate is FMOD automation quantized to?