Incorrect line endings in Fmod plugin bundles

Hi there!

having this error message come up with my Unity project.

The devs say they’ve temporarily fixed it by changing the Fmod code but is there a better solution?

Don’t think im using any of these plugins in Fmod studio yet, if that helps to know

thanks in advance!

This isn’t an error, it’s trying to stop the Mac libs getting corrupted- though if it’s popping up every time you open the Editor then something is wrong. I’m guessing your source control keeps switching the line endings in these files. If you are using git then you should be able to work around it by adding a .gitattributes file to your project with this line in it *.bundle text eol=lf, to ensure that Mac libs always use line feeds.

Hi @jeff_fmod, I’m currently running into this same issue on a project, but we’re using Perforce instead of GitHub. Is there a different solution for those using P4 for source control?


You would have to set up the same file ignore system just with Perforce. How to do that is explained on the perforce website here: Excluding Files from Helix Server Control.

Hi @Connor_FMOD, thanks for the advice! I’m still slightly confused after adding the *.bundle text eol=lf line into the .p4ignore file. It doesn’t seem to work the way I was expecting, but just ignoring files with such name, and the perforce website doesn’t really specify that.

Should I be creating another file like .p4attribute or sth?

My apologies, I have pointed you in the wrong direction.

To configure p4v go to Connection -> Edit Current Workspace then clicking the Advanced tab and changing the value in the line ending characters for text file box. More info on the options can be found here:

Again my apologies for the mistake.

Thank you so much for the update! This is super helpful!

1 Like