License error with Unity Basic (non-Pro)

I’ll throw my hat into the “Where’s the FMODAssets folder” ring. I can’t find the FMODAssets folder anywhere in the project menu. I’ve got the StreamingAssets folder with FMOD_bank_list.txt, Master, Master files inside, but FMODAssets is nowhere to be seen.

Also I’m not exactly sure what I’ll eventually be assigning to the FMOD_StudioEventEmitter script.

I am getting this console error:

Would that be affecting anything or the cause of my problems?

Any help is greatly appreciated.

Hi Clark,

That suggests the integration cannot find the native FMOD libraries, make sure you imported all of the Plugins directory.

For Windows the required files are:

For OSX the required files are:

I am using the download from the download page and having the same issue, however I think I know the cause.

Right before the “DllNotFoundException: fmod” I get “License error. Plugins are only supported in Unity Pro!”

I don’t have a Unity Pro license so I cannot import native code plugins as native plugins are a Pro/Mobile only feature. … ugins.html

I assume pushing to a device (iOS/Android) will work (Haven’t had time to test it yet), if it does it’ll just make debugging a bit slower as I can’t test in the editor.

I think a disclaimer stating that a Pro license is required for Desktop use might be needed.

Also are any example scenes or projects going to be available?

Hi Taz,

Thanks for the detailed information.

That would explain it yes, I didn’t realize that you need pro to use plugins in the editor. I will see if I can find a way to make it work in the editor without a Pro license for iOS/Android developers.

There are no example scenes at the moment, I will see if I can put something together it will probably be quite simple.

Hi Peter,

No problem, I’ve learnt over the years that if I can’t solve something myself, give as much information to someone that can.

Any examples, no matter how small, will help. I’m sure I can figure things out from the provided scripts, its just seeing something in use is easier to understand.

I intalled Unity Basic on a spare machine here and tested out some changes, can you try out this new version of the integration and let me know if it works for you? ... itypackage

When you click “Refresh event list” it should print a message saying it is running in compatibility mode for Unity Basic, then everything should work inside the editor as expected.

I did just encounter an error.

After having the project in a ‘working’ state (having refreshed at least once so the dll’s are moved and loaded), I reimported the plugin which re-added the dll’s to the plugin folder, the refreshed again, causing the dll moving code to run again, at which point the error occurred. I believe it to be cause by the dll’s being loaded in the editor and locked, as I couldn’t even delete them in explorer and they stay locked until the editor is closed. From what I could find out there is no way of telling Unity to unload dll’s.

I was actively trying to break it, but this situation could arise if someone is working in a project and decides to import a newer version of the plugin.

Seems to be fine so far. Only checked on my windows machine.

I looked at the editor code and it is only doing the file check/move for the “Refresh”, if the about option is clicked before refresh is ever called it will still error, once refresh has been clicked once about works fine.

I’ll fix that up for the next version.

Good point, I think will I just prompt the user to restart Unity if the DLLs are locked.

Edit: I have uploaded a new version of the integration which includes both of these fixes … itypackage

Hi everybody,

I get the same problem with the latest version of the plugin (10206), running on OSX 10.6. The “Streaming Assets” folder is created, but I can’t find “FMODAssets” folder anywhere. I get the following error:

DllNotFoundException: Exception of type 'System.DllNotFoundException' was thrown.
FMOD.Studio.Factory.System_Create (FMOD.Studio.System& studiosystem) (at Assets/Plugins/FMOD/Wrapper/fmod_studio.cs:115)
FMOD_StudioSystem.Init () (at Assets/Plugins/FMOD/FMOD_StudioSystem.cs:167)
FMOD_StudioSystem.get_instance () (at Assets/Plugins/FMOD/FMOD_StudioSystem.cs:66)
FMOD_Listener.LoadPlugins () (at Assets/Plugins/FMOD/FMOD_Listener.cs:128)
FMOD_Listener.Initialize () (at Assets/Plugins/FMOD/FMOD_Listener.cs:95)
FMOD_Listener.OnEnable () (at Assets/Plugins/FMOD/FMOD_Listener.cs:17)

I tried with both Pro and Basic versions of Unity and had the same problem. Thanks for your help!

That error indicates that the fmod.bundle was not found or loaded correctly. The native code for the integration relies on fmodstudio.bundle which depends on fmod.bundle. Can you please send an email to so I can get some more details from you?

It would also be good to know which version of the integration you are using? Is it the latest version 1.02.06?

Hi Peter,

Thanks for your reply. Like I said in my previous post, I used the latest version of the plugin (1.02.06). I tried to use the plugin with the same versions of Unity on OS X Lion (10.7.5) and it worked. There seem to be a problem with Snow Leopard??

I’ll send an e-mail to the address you gave me.

1 Like