Links work debug but not release - need help confirming what I messed up

Hi all
I have FMOD low level running perfectly in DEBUG x86 using fmodL_vc.lib & fmodstudioL_vc.lib.

I switch to RELEASE x86 - I have the files linked fmodL.dll &fmodstudioL_vc.lib

Then I get this error
1>------ Build started: Project: xxxxxxxx, Configuration: Release Win32 ------
1>\FMOD\lib\fmodL64.dll : fatal error LNK1107: invalid or corrupt file: cannot read at 0x338

I’m sure it is something easy to fix - I am just not sure what exactly.

All help is appreciated - thanks in advance!

You mention you are linking fmodL.dll and fmodstudioL_vc.lib, should that not be fmodL_vc.lib and fmodstudioL_vc.lib?

Also, in case it’s relevant, what version are you on?

I tried that I still get

1>LINK : fatal error LNK1181: cannot open input file ‘fmodstudioL_vc.lib’

If I remove fmodstudioL_vc.lib & only use fmodL_vc.lib -

Version 2/8/19 1.10.15 - Studio API minor release (build 103907)


Have you looked at our examples to compare to what you are doing?

The DLL needs to be copied to the application directory (next to the exe) so the app can find it at runtime.

I deleted them and re-copied to the /release/ build folder - worked :slight_smile: thanks

must have been a corrupt file :=|