Loading MetaXRAudioFMOD

I seem to be having trouble loading the MetaXRAudioFMOD plugin for Quest. It’s working on Windows just fine. I am following this guide:

But when I build my game, the plugin is not loading.
I have added libMetaXRAudioFMOD to my Dynamic Plugins under FMODStudioSettings, set the libMetaXRAudioFMOD.so file to only include Android, CPU = ARM64, Shared Library Type = Executable, and Load on Startup = true.


Thank you for the information. Could I please grab some more details:

  • What version of the FMOD integration are you using?
  • With the logging level set to Log and API Memory Tracking enabled, could you please share the logs when launching the app on a device?

Hi Connor,

I was able to fix this on my own, and the problem was when I entered the file name in Platform Specific > Android > Dynamic Plugins I had entered it as ‘libMetaXRAudioFMOD’ as that is what the file name is called.

By changing the entered string to ‘MetaXRAudioFMOD’ without ‘lib’ in the front it was able to load on Quest.

1 Like

Thank you for sharing the solution