Loop autopitch audio


(mike) #1

Hi
I want to loop an audio and use autopitch modulation. But this gives some repeating wave alike sound. How to avoid such?
Many thanks


(Joseph Harvey) #2

I’m afraid I don’t understand what you’re trying to do. Could you please explain in more detail what it is that you are trying to achieve?


(mike) #3


as you can see I’ve autopitch. Sonds fine depending engine speed, but has kind of waving, repeating sounds. How to fix this?
Thanks


(Joseph Harvey) #4

Unfortunately, I can not identify the problem you’re hearing from your description of it or that picture. Are you able to send us a copy of your event?


(mike) #5

Is there a filter etc. to reduce sound repeatings? Should be very common for ex. with car engines etc.


(Joseph Harvey) #6

The most common way to avoid repetition is to use a multi instrument that contains multiple different source audio files.

The second most common method is to introduce random variation by adding a random modulator to the pitch of an instrument, but this generally does not work well in conjunction with most events that feature autopitch modulation.


(mike) #7

Thanks. With adjusting pitch values I get it almost ok. Could you give me a link/instructions for a simple fmodstudio example on how to use multiple sounds with autopitch? How to set a sound to only play for ex. pitch values 0.8-1.0 and the other sound 0.0-0.7?


(Joseph Harvey) #8

To do that, just place each sound into a different instrument on different parts of the parameter such that one runs from the parameter value that’s 8/10ths of the root pitch position to the root pitch position, and the other runs from parameter value zero to 8/10th of the root pitch position.