Missing FMOD folders?


I recently did a fresh clone of our audio GIT repo for one of our games, and when opening up the .fspro I got the following message:
The “Recover” option seemed to work fine, but did I forget to commit something? Or are these folders that Studio generates based on the contents of my “Metadata” folder, and those files are located outside of the FMOD project folder (hence why I never had the option to commit them)?


This means all the metadata for each of those items listed were not included in the project’s Metadata folder. Likely this means you would just be opening up a blank project.

Can you confirm that the FMOD Studio project your git repo does have a metadata folder and that folder is populated? You will need every directory and sub directory in the project for it to open correctly.

Thanks, Richard. This is what the metadata folder looks like for the source and the resulting clone of the repo:

The reason I’m cloning a new GIT folder is because we were originally using SVN and switched to GIT. So I currently have two copies of the FMOD files on my computer. One copy is the SVN folder that was used to create the GIT repo, and the other is what I got when I pulled/cloned the GIT repo to my computer. So I would expect that any missing files would exist in my SVN copy, since I don’t get the same error message when opening the .fspro in the SVN version. But I’m not seeing anything obvious missing.

When I compare the file size and number of files in the metadata folder between the source SVN folder and the GIT folder, they’re very similar. They’re not identical because I didn’t commit the contents of the Profiler or Sandbox folders.


Just to provide more info, I forgot that GIT will not retain empty folders unless I tell it to, so the transition from SVN to GIT likely omitted folders like:

And as I mentioned above, I deliberately didn’t commit:

So would those missing folders be enough to trigger that Warning message.

I think the reason you see those folders in my Windows Explorer screenshot above is because I ran the Recover process once, but didn’t save, so those folders may have been created despite me not hitting save. That being said, I’m not sure why I got the Warning message the 2nd time I opened the project, if those previously missing folders now exist.

I’ve tested by pushing an FMOD Studio project up to a git repository and pulling it down with no issues. This happens with and without those folders you mentioned in the first list, however it seems the recovery dialog appears if you don’t include the SandboxFolder. Recovering the project puts it back into a workable state with no loss in data, as far as I can see. I would need to investigate further as to why it claims the other folders such as Master Event/Bank/Asset folders are missing, but otherwise it seems to be working as intended. If you are worried about this error, please check in the SandboxFolder folder.

If you recover the project, it will generate the necessary folders and xml files and store them into the .unsaved folder of the project’s root directory. It will stay there until you save the project and then they will all be moved into the Metadata folder. If you don’t save the project it puts it back into its previous state in which it will ask you to recover again on load.

Thanks a lot, Richard. That all sounds good to me. Everything looks good inside of Studio, but I appreciate the confirmation that I’m not missing something critical.