Recovery issue / error opening project

Everytime I try to open a project, I have a pop up message: could not be loaded as the version incompatible, it says please make sure you have the correct version.

I do have the correct version, in fact, I have all the version that exist on the planet… I have even tried with the latestversion, nothing opens that project.

Sometimes I have a message asking : would you like to attempt recovery of the project? I click ok, then it says : The project has successfully been restored to a working state. BUT… still, I can only see an empty project.

Can you please help, it’s really frustrating asI can’t open a project.


If you’re trying to open the project by double-clicking on its .fspro file in Explorer or Finder, be aware that this attempts to open the project in the version of FMOD Studio that you installed most recently, which may or may not be the most recently installed version of FMOD Studio. To open the project in a version of FMOD Studio other than the most recently installed version, first launch the version of FMOD Studio you want to use, then load the project by selecting “File > Open…” in FMOD Studio.

If that’s not the issue, try opening your .fspro file in a text editor such as Notepad. You should find that the file is extremely short, but includes a line that looks something like this:
<objects serializationModel="Studio.02.02.00">
The number at the end of that line (02.02.00 in my example) should be the earliest version of FMOD Studio that can open that project.

If you can’t open the project in the version of FMOD Studio listed in the .fspro file, it’s likely that your project has somehow become corrupted. If this is the case, you will have to restore your project from backup.

Hi Josph, thank you for your reply… I’ve tried everything, none of these work tbh… it is the latest FMOD ( I have 7 versions, none of them open any project ) , I couldn’t open any another project basically, except the demo and now I have a message in another project : Failed to clean up ‘unsaved’ directory…

and going back to the previous one, although it says: The project has successfully been restored to a working state. The project is empty…

The “The project has successfully been restored to a working state” message indicates that the project previously contained one or more invalidities, most likely as a result of the project being corrupted. When FMOD Studio attempts to fix invalidities, often the only thing it can do is remove the invalid content - which may explain your empty project.

It sounds like something is causing the projects you make yourself to become corrupt. Do you use any form of source control outside of FMOD Studio’s built-in integratins? Is the folder or drive on which your store your FMOD Studio projects synchronized to a file upload or virtual drive service, such as Dropbox? If you answered “yes” to either of those questions, that might be the cause of the issue, as such services often block FMOD Studio from correctly updating the files of a project, which results in project invalidities. Disabling such services should allow you to create new projects that don’t suffer from these problems.

I seriously don’t know what it is but it’s the same story: Restore, Recover, OK and then nothing, with all the projects and it happened before. The only thing is, I have to teach and grade FMOD and it’s frustrating like this. All projects can’t be corrupted… if it was one then yes.

I don’t have anysource control outside I know of

I appriciate your help though, thanks

I think it might be my mac mini with a M1 chip, I’ve managed to open it with my 2015 macbook pro, I can find a way around it, but it used to work better on my M1 computer

If it used to work better on your M1 computer, something must have changed. Perhaps its hard drive is failing, or some new or recently-updated piece of software is interfering with FMOD’s ability to load or save projects?

Unfortunately, there’s no way for us to diagnose the issue without having access to the machine in question. I can only suggest you use a machine that does not fail to load projects in this way.

I got the same error, and I am using GitHub for my project.

We have had errors with trying to share banks and such, but after the work I did on Friday, those projects are no longer accessible on Saturday.

Does this mean this is a GitHub issue? Is there a better way to work using Github?
Thank you in advance, I will keep researching.

Unfortunately, FMOD Studio is not compatible with most applications that automatically synchronize local files to a cloud-based folder, as those applications frequently open those files for read or edit, which blocks FMOD Studio from being able to read or edit those files. To avoid this issue, do not use any application or service that automatically synchronizes your FMOD Studio project or its containing folder with a cloud-based folder or external server unless it does so through one of FMOD Studio’s source control integrations.

ok, thank you!