Music tracks not playing on iPhone X

I have been using FMOD for a while in my iOS game. iPhone X alone will not play music tracks in my game. All other audio is fine. It’s almost as if the bus that has the music tracks is completely muted.

I have tried upgrading to the latest versions of Studio and API, rebuilt my banks with no luck. The same banks play perfectly fine on other iOS devices.

Anyone else seeing this? Ideas?


Are you getting any errors or warnings in the logs or when attaching a debugger?

Actually, it’s a user error.

I was befuddled all this time because the initialization returned no error. Turns out that the problem was on my end.

I have a system to check the device version and appropriately cut out playing music on lower end devices. That system worked by comparing utsname.machine with the string identifiers for devices and not playing the music for lower end devices. I ended up using a strNicmp function for that and was passing in the length of the string I was comparing to. iPhone X identifies itself as iphone10 and my check for iPhone1 ended up returning successful .

Sorry for the trouble.

No worries, just glad you found the solution.

This was a user error.

My system to identify the device and conditionally turn off music was causing this. I had a bug in my code where the system was identifying the device as iPhone1 instead of iPhone10. (I was using strNicmp, passing in the length of “iphone1”).