No audio with FMOD in Unity Editor? It may be muted

This is just a PSA. I’ve been programming with Unity for a long time but this still got me :slight_smile:

I see several abandoned “no audio” threads in this forum. I myself had this issue and I spent several hours reading through setup guides and scratching my head as to why I could not hear anything.

I connected the profiler and saw events trigger, these were 2D events and so it should be impossible for them to be “too far” from the FMOD listener.

Turns out I had “Mute Audio” selected in the Game window. Not sure if it was me or another programmer, but there it is. Unclicking it fixed my “I cannot hear anything and FMOD is broken” train of thought :slight_smile:

Hope this helps, I think it should be added for the FMOD FAQ as silly as that sounds.

1 Like

goddamnit :rage:

I spent a long time trying sort this “sound issue”. When I saw people saying “turn on the audio toggle on the editor” I was trying this one.
audio

thanks man. you are my personal saviour for the day :slight_smile:

I know, right? :smiley: