"Objects have the same fully qualified name but different paths"

Running a project with UE4. Everytime I create a mixer snapshot and build the banks, I get this error.

Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/CoreUObject/Private/UObject/UObjectGlobals.cpp] [Line: 2381] Objects have the same fully qualified name but different paths. New Object: FMODSnapshotReverb /Game/FMOD/Snapshots/New_Snapshot.New_Snapshot Existing Object: FMODSnapshot /Game/FMOD/Snapshots/New_Snapshot.New_Snapshot

Any ideas? It only happens with mixer snapshots, everything else runs fine

1 Like

What version of Unreal and FMOD are you using?
The error message suggests you have two mixer snapshots called “New_Snapshot”, is this the case?

I’m using UE 4.26 Chaos and Fmod Studio 2.02.04.

I did have issues earlier with duplicates of the Fmod integration in Unreal, so that might be a possible answer. But in my current project I don’t have any snapshots. Everytime I make a new snapshot UE crashes, no matter what the name of the snapshot is.

I have not been able to reproduce this issue with these versions. Perhaps try deleting FMODStudio from your project’s plugin folder, and replace it with a fresh copy of 2.02.04. Then open your FMOD and Unreal projects and run “Help>Validate FMOD” to make sure everything is setup correctly.

1 Like

Hi Jeff

I tried deleting FMOD Studio from my plugin folder as well as trying to remove everything Fmod-related to the project, but still no luck. The error always reappears when I create a snapshot. I have tried to rename it differently, putting it in groups, creating blending or overriding snapshots but still the same results. Got any more ideas by any chance?

This is the full error I’m getting

`Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/CoreUObject/Private/UObject/UObjectGlobals.cpp] [Line: 2381] Objects have the same fully qualified name but different paths. New Object: FMODSnapshotReverb /Game/FMOD/Snapshots/Group/BlendingSnapshot.BlendingSnapshot Existing Object: FMODSnapshot /Game/FMOD/Snapshots/Group/BlendingSnapshot.BlendingSnapshot

UE4Editor_CoreUObject
UE4Editor_CoreUObject
UE4Editor_FMODStudioEditor!FFMODAssetBuilder::CreateAsset() [C:\jk\workspace\Build__2.2__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODAssetBuilder.cpp:532]
UE4Editor_FMODStudioEditor!FFMODAssetBuilder::BuildAssets() [C:\jk\workspace\Build__2.2__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODAssetBuilder.cpp:143]
UE4Editor_FMODStudioEditor!FFMODAssetBuilder::ProcessBanks() [C:\jk\workspace\Build__2.2__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODAssetBuilder.cpp:47]
UE4Editor_FMODStudioEditor!FFMODStudioEditorModule::ReloadBanks() [C:\jk\workspace\Build__2.2__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODStudioEditorModule.cpp:1229]
UE4Editor_FMODStudioEditor!FFMODStudioEditorModule::ProcessBanks() [C:\jk\workspace\Build__2.2__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODStudioEditorModule.cpp:387]
UE4Editor_FMODStudioEditor!TBaseFunctorDelegateInstance<void __cdecl(void),FDefaultDelegateUserPolicy,<lambda_b89097783886ec9b87f132c6787c1a3c> >::ExecuteIfSafe() [C:\Data\UE4\Unreal Engine\4.26\Engine\Source\Runtime\Core\Public\Delegates\DelegateInstancesImpl.h:838]
UE4Editor_AssetRegistry
UE4Editor_UnrealEd
UE4Editor_UnrealEd
UE4Editor
UE4Editor
UE4Editor
UE4Editor
UE4Editor
kernel32
ntdll

Another idea would be that there is some corrupted file in the content directory, perhaps try deleting everything in Content/FMOD and re-validate FMOD inside the UE editor.
If that doesn’t work I think I am going to need a reproduction- if you could please upload an FMOD Studio project and UE4 project to your FMOD Profile then I will take a closer look. You can strip it back as much as you like, I think just a blank map and blank FMOD project should be enough to reproduce this issue.

Not sure if this is any help but I ran into this the other day. I deleted the ‘/’ on the end of the ContentBrowserPrefix in DefaultEngine.ini and started seeing the same error.

[/Script/FMODStudio.FMODSettings]
ContentBrowserPrefix=/Game/FMOD                       <-- BAD
ContentBrowserPrefix=/Game/FMOD/                      <-- GOOD

When FFMODAssetBuilder::CreateAsset runs, the replace on the ReverbPackagePath fails silently as it’s looking for ‘/Game/FMODSnapshots’ and just returns the unmodified Outer Path. It then tries to create the reverb asset with the same path as the snapshot asset.

It’s worth checking you projects settings/DefaultEngine.ini to ensure that trailing slash is there.

1 Like

Oh wow, that’s so wild. Can’t believe it actually worked! Thank you so much!