Panning Issue in 3D Space & Object still playing after editor stop


I’ve just started implementation on a game being fairly new to FMOD and I’m experiencing a weird panning issue. I’ve placed a test sound in the world at a 3D position but the sound seems to be too harshly panned to the left or right on approach even though the object is say 50% either way on the screen. I’ve experimented with the sound size and the pan overrides but it’s not precise enough. any ideas?

Also the sound from the event emitter keeps playing even after stopping play mode. we haven’t removed the unity audio listener fully yet and/or deleted all unity audio source references yet so maybe that’s a a possible issue.

I’m using FMOD 2.02.04 & Unity 2021.2.3f1

Many Thanks

That could be related to the still pending bug I reported here.
Are your events on a specific plan (ie. {x,y} or {x,z})? How are configured the listener up and forward vectors? Also, what kind of game is it? 2D, 3D? What type of camera view?

Hi mate thanks for the response.

It’s a 3D game. I’m fairly new to FMOD and unity and have worked purely on sound design before so I’m basically learning as I go and tackling a lot of problems as they come up for the first time so I’m not sure about the configuration of the listener. I was unaware you could even change settings for the listener. It’s a perspective camera though.

The listener matches by default the camera view, so you may not be concerned by the bug I was talking about.
The sound size should be the way to go. You said you’ve already experimented and it’s not precise enough. Could you be more, hum… precise, yourself?

What do you mean by “stopping play mode”? You have to specifically stop the event, not just stopping the action that triggered the play.