"Parameter only" sound stops playing at max value, bug?


Whenever I play an event that only has sounds on a parameter and not in the timeline, the event will stop if the parameter is dragged to the max value of that parameter.
Is there a way of stopping this? Seems like it should include the top value as part of the range.

Here’s a video of this happening.

Try setting the nested events to persistent. You do this on the master deck controls of the event. There may be some automation or conditional parameters that are killing the audio to those nested events which will turn them off and they won’t retrigger until your parameter moves off of them and back on.

You say that your event stops when you increase the value of its parameter to the maximum, but the video you attached does not exhibit that behavior. Rather, the event in your video continues playing normally for a short time after the parameter reaches its maximum value, and stops only when all the instruments it contains have finished playing. This is the normal and expected behavior of a non-persistent event.

However, I suspect your instruments do not extend all the way to the maximum value of the parameter. Here’s why:

  • The “Nested Event (2)” instrument on your event’s “Audio 1” audio track appears to stop as soon as your “overheating” parameter’s playback position is dragged all the way to the right, and then starts again immediately when you drag the playback position back to the left. This suggests it’s being untriggered when the parameter reaches its maximum value, and then reteriggered when you reduce the value of the parameter again.
  • The “Nested Event (4)” instrument on your event’s “Audio 2” audio track appears to stop naturally a short time after it is triggered, but does retrigger when the parameter value is reduced below the maximum.
  • The “Nested Event (3)” instrument on your “Audio 3” audio track appears to loop a specific number of times when triggered. When you drag the parameter playback position to the left after dragging it to the parameter’s maximum value, this instrument is triggered again, resulting in the instrument briefly having a two internal playback positions.

If you don’t want these instruments to be untriggered when the parameter is at its maximum value, you should click and drag their right edges to the right until they extend to the parameter’s maximum value.