Perforce Checkout always asked for "BankLookup"

Any user on the project launching unreal project with FMod (and Perforce) is asked to checkout this file, what is it ?
Do you know how to prevent asking for checkout everytime ?
(checkout it and submit it does not seems to help)

Thanks !


Which version of FMOD Studio and the unreal integration are you using? In early versions of the integration, this file was regenerated at the start of every session, but in more recent versions it is only when the banks have been changed.

If I understand well, if sound designer updates banks, he needs to send BankLookup to source control, and no other user should have to checkout it ?
We use 2.02.05, is bug supposed to be fixed in this one ?

I’ve checked with the developer who worked on this bug - and it seems like there’s an easy workaround: Set your source control to ignore the file. It’s automatically generated locally, so excluding it from your source control depot won’t cause any problems.

This issue was supposed to have been fixed in versions 2.01.14 and 2.02.05. I’ll have to investigate why it’s still occurring in the latter.

In any case, excluding the file from source control should allow you to avoid the issue, as I mentioned above.

Thank you.
Maybe on a future release this file cound be moved to ‘Intermediate’ Unreal folder, which is made for generated files and already excluded from source control for anyone using Unreal.

Anyway, a you mentionned, a good workaround, added this to .p4ignlore file

News on the subject, we were wondering why we had some sound problems on builds made by our buildmachine.
We found that automated process could’t checkout file (build machine should never modify data), and this was causing some weird issues on some of the sounds.

We fixed it by removing manually read-only flag put by source control.
attrib -R [...]Content\FMOD\PrivateIntegrationData\BankLookup.uasset