Phonon_fmod.bundle' : ERR_FILE_NOTFOUND

Hey everyone - I know this topic has been posted here before, but I can’t for the life of me solve this and am hoping someone here can point me in the right direction.

Trying to get the Steam Audio plugin installed into a Unity project. I’ve got it functioning properly in FMOD, but continuously get this error (with no audio) in Unity. I’ve followed the file path where the console says it can’t find the file, but see that the file exists in that spot? Attached are screenshots of the console and the file it’s looking for.

I also want to double check on the location of the files that I’m copying over from the Steam Audio ‘Getting Started’ document. When I copy these into the actual project directory (not where it’s installed on my computer) fmod immediately crashes when I try and add the plugin to an event.

This would be:
Unity Project > Project FMOD Folder (which contains the .fspro file) > Plugins (had to create this folder)

When I add the files from getting started to the installation location on my computer, I can get the plugin to run on my computer which would be:

(Right clicking on the FMOD studio Application and selecting ‘Show Package Contents’) > Contents > Plugins

On the Unity side, I’ve added “phonon_fmod” to dynamic plugins for both Editor and Default (should this be on both?). After installing the ‘SteamAudio.UnityPackage’ into the project, I was able to see the Steam Settings at the top and have set the Audio Engine to FMOD Studio, per the installation instructions.

Lastly - with all of this done, I’m always getting a “Phonon.Bundle.Dll is damaged and can’t be opened” error as well. I’ve tried following the directions to ctrl/click and open to add this as an exception around the mac system security, but this hasn’t changed the behavior here.

This project uses:
FMOD Studio 2.02.21 (installed the latest FMOD/Unity package yesterday)
Unity 2022.3.11f1
Macbook Pro M2 Max Sonoma 14.2.1

Please let me know what other info you need! Would REALLY appreciate any help to point me in the right direction!

Have you tried to do xattr in the terminal on the bundle?

cd <plugin-directory>
xattr -d phonon_fmod.bundle
Maybe you also have to do it for the contents inside the bundle, if that doesn’t work.

But I’m no expert. On windows, I have steam audio working good. Both ways of adding plugins to fmod work for me there.
But it sounds like a typical mac certificate havoc…

1 Like

Ah! This was it! Looked this up and found a detailed walkthrough of this process from this youtube video. There are a couple of extra steps at the end that look like it’s been corrected and isn’t needed anymore (the file path error)

(Time stamped for the console instructions)

Thank you!!

Great! Happy to hear that! :blush: