'FMODStudio' failed to load because module 'FMODStudioOculus' could not be found.


(regallo) #1

Unreal 4.75
Oculus dk2

I get this error when trying to play a windows executable I’ve created
Plugin ‘FMODStudio’ failed to load because module ‘FMODStudioOculus’ could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.


(Geoff Carlton) #2

Hi,
What configuration did you build with? We currently include built plugin binaries for Win32 Shipping, Win64 Development, Win64 Development Editor.

Note that this should improve in future. Epic are doing work in 4.8 to improve the build process for plugins which should make it easier for us to include a fuller set of configurations or even have the libs build on the users end for any engine/configuration they need.


(Sander) #3

Hi Geoff,

My project team receives the exact same error upon building: “Plugin ‘FMODStudio’ failed to load because module ‘FMODStudioOculus’ could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.” We build with Win64 development binaries and work in UE4.7.3.

In this thread (http://52.88.2.202/questions/question/plugin-fmodstudio-failed-to-load), where a very similar issue is addressed, you mention that it is a known issue with Epic that affects all plugins, and that creating a code project is currently the only workaround. Is any updated information about the issue available?

Thanks (for FMOD’s utility as well as the swift support the FMOD team provides)!