Pops and Clicks When Looping


(frnacisco) #1

Hi guys. I’m new in this forum. I came here to make a question and i hope you answer because i can’t find a solution.

So I have a looping ambient sound. The problem is that when make it loop i always hear a click or a pop when the loop starts over. The thing is that the transition between the end and the beggining is suposably smooth. Check this screenshoot: http://prntscr.com/anysh9, and this one http://prntscr.com/anyskz (they are the same screenshot, one zoomed in and one zommed out).

In Pro Tools the sound loops fine, the only problem is here in FMOD. Any help would be appreciated.


(Jesse Lyon) #2

The screenshot to me looks like you have extended the sound and trying to loop it halfway through the second loop (which would likely pop). The little indentation at the top and bottom of the waveform shows where the original loop should end, so you should either trim the region back to that point, or delete the sound from the track and pull it out from the audio bin again. This will reset it to the original default length of the loop, and then you can add your loop region again.


(frnacisco) #3

i’m afraid i couldn’t understand your explanation. What indentation are you talking about, and what is the point that you are referring when you say that i should trim the region back to that point?


(frnacisco) #4

i’m afraid i couldn’t understand your explanation. What indentation are you talking about, and what is the point that you are referring when you say that i should trim the region back to that point?


(Jesse Lyon) #5

In your second screen shot there is an indentation in the region near where your cursor is. Thats where the original file ends and should loop around to the start (assuming you edited the file in a DAW to loop properly). If you pull the audio file out of the audio bin again to the track, the region on the track should end there. At some point you must have extended the region on the track to make it longer then the original file.


(Sylvain) #6

Try making your loop sounds start and end with a zero value. Make in PT inaudible small fades on start and end of your sounds…


(frnacisco) #7

I already did that and i can listen to the pops.


(frnacisco) #8

ISN’T THERE A WAY TO CROSSFADE THE END AND THE BEGGINING OF THE LOOP IN FMOD?


(Jesse Lyon) #9

You should create your seamless loops in a DAW like ProTools. FMOD isnt designed to be an audio editor like this.


(frnacisco) #10

I do seamless loops in Pro Tools, but in FMOD the waveforms doesn’t match, therefore i hear a click


(Thuan Seah Tan) #11

Hi frnacisco,

Would you be able to send us a project with the event and sound demonstrating the project? You can send it as an attachment to support@fmod.org and provide a brief description of the issue in the email body. It would also help if you could let us know the build of Studio you are using.


(Thuan Seah Tan) #12

Hi frnacisco,

Just like to follow up on the pop and click issue. If you are still having a problem, feel free to send a demo project with the event and assets to support@fmod.com and provide a brief description of the issue.


(Jesse Lyon) #13

I just came across this same issue and found the cause of the problem and solution…My loop was playing fine in FMOD during audition, no pops or clicks, but was popping on loop in game. The issue is due to the compression setting on that sample in the Audio Bin, Once I raised the compression quality to 100%, the pop in game went away. This must be due to a combination of sample rate of the file and the lower compression setting not allowing the sample to loop at the exact same point in the file.


(Jesse Lyon) #14

I just came across this same issue and found the cause of the problem and solution….My loop was playing fine in FMOD during audition, no pops or clicks, but was popping on loop in game. The issue is due to the compression setting on that sample in the Audio Bin, Once I raised the compression quality to 100%, the pop in game went away. This must be due to a combination of sample rate of the file and the lower compression setting not allowing the sample to loop at the exact same point in the file.


(frnacisco) #15

Where do you increase the compression quality? In the File in AudioBin or in the Master Bank?


(Jesse Lyon) #16

If its an older version of FMOD its done at the bank level. If you have the latest version, it can be set per .wav file in the Audio Bin


(Thuan Seah Tan) #17

Hi Jesse,

Wondering have you got a chance to update to 1.08.08? In the latest release, you can now audition the audio file in its compression form and looping. Wondering if the pops and clicks are present when auditioning in the asset view.


(Jesse Lyon) #18

Yes, I can also hear the pop when I audition the loop in the audio bin at lower sample rate. This is a nice feature, although is it possible to apply/audition the compression at the Event level? This would be more useful in order to hear layered sounds together with compression.


(Jesse Lyon) #19

Im not sure if the Vorbis Quality setting is doing anything though, it sounds exactly the same at 1% as the 100% setting.


(Thuan Seah Tan) #20

Hi Jesse,

Is there any chance you could send us a copy of the loop for testing purpose? As for the Vorbis compression quality, the major difference would be the filesize and if you are happy with the quality at 1%, then I would reckon go for it :slight_smile: