Popping when looping music, my mistake?


I’m fairly new to all this, so this may just be a mistake on my part, but I figured I’d ask anyway if there’s something that can be done.

So I’ve made a few looping tracks in Ableton (looping enabled in export as well) and when looping two of them in Ableton and Windows Media Player, I get no popping at the end/beginning. However, when looping them in FMOD, and by extension Unity, there is a noticeable pop every time.

I am a bit torn, since I know that the tracks do start somewhat abruptly, but I figure that if there was a pop, there shouldn’t really be anything noticeable once it loops back around–especially on the first track shown in the video below since it’s mostly pads and reverb that Ableton took care of–but there very obviously is.

So, given that those other two programs are leading me to believe they’re ok, is this something FMOD is doing or is it something I need to fix with my tracks?

Thank you.

Example (and for some reason it doesn’t seem like you can hear the second track’s pop very well; this adds to my confusion)


There are a couple of culprits in this situation, but a preliminary guess would be that the asset is set to “stream”, which means when playing back it will be loaded piecemeal on-demand, instead of being loaded into memory all at once. This typically incurs extra latency, especially when being seeked/looping, which may result in the popping you’re observing.

If you select the asset in the asset browser and set it to not stream, does it resolve the issue? If not, so that I can attempt to reproduce the exact issue on my end, can I get your FMOD Studio version number?

1 Like


Thank you for your response. Apologies as I had forgotten to mention, but yes I had previously tried to turn streaming off and that doesn’t seem to make any difference. Looping the assets in the browser itself still produces the same popping. My FMOD Studio version is 2.02.15.

Unfortunately I haven’t been able to reproduce your issue on 2.02.15 unless I do as you’ve noted and intentionally loop between areas with an abrupt difference in amplitude or frequency content. Would it be possible to get you to upload an audio file where you can consistently reproduce this for me to take a look at on my end? You can upload to the “Uploads” tab of your FMOD Profile.

As a workaround, however, if you add a Transition Timeline to the loop by either double clicking it, or right clicking and selecting “Add Transition Timeline”, you should be able to set the Transition Timeline to an appropriate size, and drag out the start and ends of the instrument to crossfade when looping, which should alleviate the issue.

1 Like

Hello again,

I am currently registering a project so that I am able to upload the files I’ve been using. I was attempting to use the transition timeline method you suggested*, though that would just crossfade between some portion of the first and last beat of the track, effectively skipping a bit of the last beat of the first loop, correct? So perhaps I just need to revisit how I composed the beginnings and ends of the tracks, since right now the ends of the songs resolve to how the songs begin for the last couple bars, and maybe that’s just not the best way to do it; granted it did seem to work fine on one of the tracks I made for this project. In any case, I’ll still try to upload the files once the project is approved just in case, so thank you for your responses thus far.

*(with difficulty, since I couldn’t get why the first track instance kept cutting off once it hit the transition timeline–even when trimmed–unless I trimmed the first track instance and initial loop region, then inserted the transition timeline, then extended the teal Source bracket in the transition timeline, then extended the first track instance back to its original length “under” the teal Source bracket–finally allowing it to be crossfaded with the second track instance once I dragged the orange bracket over the teal. Though I still couldn’t figure out how to overlap the two brackets perfectly since completely covering the transition region with one bracket seemingly made grabbing the edge of the second bracket impossible, given that this is all on one track since it’s just looping one file. Apologies if this was hard to follow :sweat_smile: I’m sure I just goofed and didn’t quite get it yet.)

That may be an approach to take. I’m unfamiliar with Ableton specifically, but some DAWs allow wrapping the tail of the track to the start on export, which can help with seamless looping.

As for your difficulties with the transition timeline, it’s likely that the option “Show Overlapping Instruments In Lanes” option in the “View” menu is disabled - enabling it will separate overlapping instrument into different rows within a given Audio Track, which should address your problem.

1 Like

As a quick reply to that, yea Ableton does have that wrapping ability, which I do have enabled, which is a good part of the reason why I was surprised to have such a noticeable pop during the loops–and why I was not extremely surprised that there would be some sort of pop right when the song starts for the first time since there would be some residual levels from the tailing effects. I’ll check that transition timeline tip though, thank you for that info. I’ll still be sure to upload the files I’ve been using once I have the permissions. Thank you.

1 Like

And almost right after I send that, I find a solution. (Additionally, yea, for some reason that View option was disabled, though when I booted up FMOD to check if it was, it was already on this time? Don’t know what changed).

But yea, I figured out the problem, and it was a very strange issue. So as I went into Ableton to adjust the composition, I figured I’d check to make absolutely sure that the waveforms weren’t clashing at the looping point. To do this, I imported the exported WAV file back into the original projects I had composed in and zoomed in on the transition points, and it does appear that an extremely small nodule in the waveform had been produced during the export despite the waveform ends otherwise matching up perfectly(? Very possibly an Ableton bug, probably explains why one of my three tracks exported fine, and why I wasn’t getting any popping anywhere else).

So, I exported those WAVs again after applying some very small fades at the ends. Magically, no more popping in FMOD. While it does seem stupid of me to miss something so small, in my defense, I had already tried adding fades to both ends of the files in FMOD while troubleshooting, and that wasn’t working for some reason; the popping wouldn’t disappear unless I made the fade so large that it cut out a noticeable portion of the track, which led me to believe the problem wasn’t so small. Though, it was weird how I didn’t notice the popping in any software before importing it into FMOD in the first place; it just seems to work differently?

But yea, apologies for making such a fuss over something that turned out super avoidable. This has been very helpful, and I’m very grateful for the quick and detailed responses–far and away better than Ableton’s customer service I’ll add. So yes, thank you very much for your assistance.

1 Like

No problem! I’m happy to hear you managed to resolve the issue.