Procedure entry point note found (Windows 32-bit FMOD Studio)

Hey guys,
I’m getting a weird DLL declaration mismatch. I’m using FMOD Studio 2.01.11 and I’ve copied over the appropriate files (headers, static lib and DLLs) a bunch of times but still get the same result. The headers are also correct, e.g., the folder matches up and the version is #define FMOD_VERSION 0x00020111

This is our own engine and not Unity or Unreal. This project was updated a couple of years ago so it’s not that old.

Any ideas?

Merry Christmas, Happy Holidays and a Happy New Year to you all!



We list the requirements for building to windows under FMOD API | Platform Details. Depending on how you are compiling your engine may be causing the issue. Specifically looking at

You will need to use the import library libfmod.a and libfmodstudio.a in order to link the 32 bit dlls.

Hope this helps!

Hey Connor, I don’t mean to be daft, but can you point me to the code or project settings where those files are imported in the examples? I see that in the docs now (I didn’t see this in the past…). Thank you!


No worries!

The files are located under (BootDrive)\Program Files (x86)\FMOD SoundSystem\FMOD Studio API Windows\api\(core/studio)\lib\x86

Then add your file directories to your visual studio project properties here

Hope this helps!

Hey Connor, I should have responded a while ago. Mea culpa! So it was an errant DLL that was in the final executable build folder (doh!).

However, did not need to include the .a libs for the 32-bit version to run. Just the regular static .lib files (with their DLLs, of course).

The examples don’t do this either.

Am I missing something critical??


Happy to hear the issue is solved!

You aren’t missing anything, I misdiagnosed the problem.

If you have any more questions please don’t hesitate to ask!