Programmer Instrument for dialogue - Can't see audio in the Audio Table

Hi there, I followed this info - “https://www.fmod.com/docs/2.00/studio/dialogue-and-localization.html
On setting up a programmer instrument with an Audio Table.

I’ve selected the directory with the audio in it, for the Audio Table, but I can’t see any of the audio coming up in the table.

I’ve attached a screenshot. I should be seeing the audio files in the Audio table yes?

Thanks!

hmm i still can’t figure out why no audio is showing in the list

Unfortunately, I haven’t been able to reproduce this issue. When I test here, audio files in the chosen directory appear in the audio table only a few moments after specifying the source directory. I therefore suspect I must be missing some important step required to make this issue manifest.

What version of FMOD Studio are you using? It’s possible that this issue only affects certain versions.

Is the path you specify on the same drive as the FMOD Studio project, or a different drive? It is on a network drive, or an external drive?

Thanks so much for the reply,
hmm, that’s strange.
It’s on the same C: drive, but it’s not in the folder containing the FMOD session.

I’m using FMOD version 2.02.07…

Im curious to know if you are able to replicate the issue with that version?

Changing to a different version of FMOD caused some issues last time I did it. I’d just like to make sure before heading down that path

That’s not unusual for an audio table. Many people prefer to keep their audio table assets outside of their project asset directories for a variety of reasons.

That version’s audio tables seem to work perfectly when I try it here.

As I mentioned earlier, I must be doing something differently to you - but I’m not sure what. Does your audio table directory use any source control software? Is it synchronized with a cloud syncing service such as DropBox?

hmmm :frowning:

The audio table directory isn’t under source control. The FMOD session folder is though, it’s sync’d via plastic.

The audio table directory is C:\ _ myname _\gametitle_New\Voice Overs\RCOM\Demo

Is it possible the underscores would cause any issues?

This might be the problem. Folder synchronization services tend to interfere with FMOD Studio’s ability to access and write to the files in your FMOD Studio project folder. This can lead to errors and project corruption.

I therefore recommend disabling Plastic, marking all files and folders in your FMOD Studio project as writeable, then trying again.

The underscores should not cause issues.

Thanks Joseph I’m looking into this now. I’m a bit confused cos I don’t even have plastic open at the moment, and it doesnt sync unless I load plastic, then check in or out with changes.

But I’m trying some stuff out with plastic.

In the meantime, I made this short video of my process of creating the programmer instrument and audio table.

Maybe it might expose something I am doing wrong?

Video of creating Programmer Instrument and Audio Table

Many source control and file synchronizing services mark files as read-only, which can prevent FMOD Studio from writing to those files even while the service is not actively running.

Ah! I think I may have found the problem.

When you create a localized audio table, FMOD Studio doesn’t look directly in the folder you select for audio files; rather, it looks for subfolders inside that folder that match the locale codes you’ve defined for your project in the assets tab of the preferences window, since it assumes you’ll be using a different subfolder for each supported language/locale. So, for example, if your game has one locale called “English” with the locale code “ENG”, and another called “Deutsch” with the locale code “DEU”, and you set a localized audio table’s path to C:\Audio, FMOD Studio won’t look for audio files in that folder, but will instead look for presumably-English audio files in the C:\Audio\ENG folder and for presumably-Deutsch audio files in the C:\Audio\DEU folder.

I can see from your video that there are no locale-specific subfolders inside the audio table path you selected, so it’s only natural that FMOD Studio can’t find any.

Hey Joseph, thank you for the continued assistance.

I disabled plastic in my “services”, then unchecked “read only” on my FMOD Assets folder(and tried it on the entire unity folder too). I also changed the directory to a folder with “ENG” and “JPN” supfolders, with all the audio in the ENG subfolder. Still the audio is not showing up in the audio table.

Egh… I have attached a screenshot →

One thing I noticed, is that if I uncheck “read only” on the FMOD or Unity folders (even with plastic disabled in services) then hit apply, and ok. When I re-load the properties of the folder, there is a square box checked in the “read only” box again.

Ok… We’ve figured it out. There was one part of the Programmer Instrument information I overlooked.

The issue was that I hadn’t defined the new locales in the assets tab of the preferences dialog.

Derp… Sorry and thanks for your help

I’m glad to hear you were able to solve the problem!