Error every frame: bind failed 10048


(Emanuele) #1

Hello everybody,

I’m using fmod unreal integration version:

“VersionName” : “1.08.04”,
“CreatedBy” : “Firelight Technologies”,
“CreatedByURL” : “http://fmod.com”,
“EngineVersion” : “4.6.0”,

in Unreal engine 4.12.5 with oculus plugin. The platform is Windows 64 bit.

I recently started getting this error every frame, but I can’t figure out the cause.

This is the loop that spams when I hit “play in editor”.

LogFMOD:Error: 'StudioSystem[EFMODSystemContext::Runtime]->update()’ returned 'A socket error occurred. This is a catch-all for socket-related errors not listed elsewhere.'
LogFMOD:Error: ‘StudioSystem[EFMODSystemContext::Runtime]->update()’ returned 'A socket error occurred. This is a catch-all for socket-related errors not listed elsewhere.
LogFMOD:Error: c:\jk\workspace\Build__1.8__UE4Libs_Win\lowlevel_api\src*fmod_os_net_winsock.cpp(207) - bind failed 10048*
LogFMOD:Error: c:\jk\workspace\Build__1.8__UE4Libs_Win\studio_api\src*fmod_asyncmanager.cpp(739) - System::update returned error 43.*

Can you help me trace the cause of this spam?
I suppose it could be some busy port that fmod is trying to bind a listen socket to, but what is the port, in case?

Thanks in advance,
Emanuele


(The Revera Corporation) #2

Having the same issue myself. Any insight would be useful. Thanks,


(Cameron Baron) #3

You will get those errors if the project is trying to use live update while the port, default is 9264, is in use. You can manually change the port number in settings or just disable live update altogether.


(Emanuele) #4

Ah! I didn’t know it. Thank you. How can you disable it?


(Cameron Baron) #5

You can find a check box in settings.
Edit->Project Settings->FMOD Studio->Enable Live Update (near the top of the list)


(Emanuele) #6

Great! Thank you!


(Emanuele) #7

I solved by myself, I found an application with a socket listening on 7681 port tcp . After closing that app, it stopped logging errors.

I’m not quite sure of the cause though, since if I restart it and launch unreal the it does not spam anymore.

I would be useful if you guys tell me the port it’s trying to bind to in the function at
fmod_os_net_winsock.cpp(207) – bind failed 10048

thanks