Sandbox preview issue

Hi there.

I am using FMOD Studio 1.08.13 on the mac and have an issue in using the sandbox preview function.

Whenever I try to drag a newly created event item into the window from the sandbox event list, I get an error popup stating:

"An error occurred while trying to create an event instance for event:/SFX/UI/Count
Check that this event has been built to a bank"

This has only started happening recently (in the last week) and I am certain that the events have been assigned and built correctly into the main bank. I have checked in my Unity build and can access the event and bank from there, which leads me to believe it has been built correctly. I have also ensured that all of the events with this error, DO NOT have the “Unnassigned” (bank related) message attached on the event.

If I create a brand new FMOD project the Sandbox behaviour is fine and works as expected. I can add newly created events to the sandbox and they work fine. Also, If I copy and paste the previously not working event into a new project and build, it works fine.

This only seems to happen on newly added events as all of my previously created events work fine in the sandbox.

I have tried multiple builds and reboots of FMOD and am at a total loss as to why this is happening. Am I missing something really obvious? Any Ideas anybody?



I am having this exact same issue, FMOD Studio 1.08.12 on mac. I know in the past I was able to use the sandbox on other projects, but I tried to use the sandbox here and it simply won’t let me place any events. I haven’t gone through exhaustively but I tried some of the first events I made as well as the most recent ones that I just created. I was trying to use multiple bank loading, so I built the problematic events to the Master Bank as well, and I also built the project, but no luck. I haven’t tried putting the events in game yet.

Hi Jacob. Not sure If this will be of any use, but for my specific issue, I actually found the problem to be with switching to use the Mobile build setting in Fmod. The way I understood the problem was that Fmod editor uses the Desktop build for the sandbox irrespective of which platform you have set the banks to build in.

So, what sorted it for me was to use “Build all Platforms” setting whenever i needed to preview things in the sandbox and I haven’t had any issues since.

Hope this helps.


1 Like