Selecting ASIO instantly crashes FMOD

#1

FMOD Studio 1.10.12 instantly crashes on Win10 1803 x64 if I select “ASIO” in preferences. What can I do to fix this? I’m using an RME Fireface 802 and all major DAWs can access the ASIO device without an issue.

0 Likes

#2

Does this still happen when you don’t have your interface connected? Do you have any other DAWs open at the same time as FMOD Studio? If so, please close those DAWs and see if this happens again.

If you see a crash report dialog, could you please send that through?

In the meantime, could you try installing ASIO4ALL and see if the same crash happens then?

0 Likes

#3

Yes.

No.

Btw, never had problems with multiple asio applications running in parallel.

How can I do that? I’m not allowed to upload such file types.

It also crashes with the ASIO4ALL driver installed. Note, I’m unable to select any specific ASIO driver at all. Switching from WASAPI to ASIO directly crashes FMOD.

0 Likes

#4

Seems FMOD crashes if the JackRoute ASIO driver is installed (extremely useful open source tool to wire multiple audio applications together).

Here is a repro case:

  1. Install FMOD 1.10.12 on Win 10, x64 (I use version 1803)
  2. Install Jack for Windows from here https://github.com/jackaudio/jackaudio.github.com/releases/download/1.9.11/Jack_v1.9.11_64_setup.exe
  3. Register the JackRoute ASIO driver by running from an admin prompt regsvr32 "C:\Program Files (x86)\Jack\64bits\JackRouter.dll"
  4. Run FMOD
  5. Switch to ASIO -> Crash

Other DAWs like Reaper or Nuendo work fine with the driver.
Even if it turns out that using the JackRoute ASIO driver within FMOD cannot be supported, FMOD should not crash at all. Marking that driver unusable, not putting the driver into the list or showing an error message upon selecting and then switching to another one if available - these are all better options.

I have another ASIO enhancement for you to consider. This is how FMOD presents the ASIO driver:

It would be better to use the key Description of the respective ASIO driver from the registry path HKLM\SOFTWARE\ASIO\$ASIODRIVER as output device name, instead.

0 Likes

#5

Thank you for bringing this to our attention. I’ve raised a bug report and we’ll look into it for a future release.

I’ve also put your suggestion to use the description key to display the name of the driver into our tracker.

0 Likes

#6

In case it helps, I submitted a couple crash reports when I got a crash with ASIO recently (using my RME HDSP9632 card). I’ve never had any luck using ASIO with FMOD Designer or Studio. I used WASAPI with Designer (which worked fine), and am trying out Windows Sonic since WASAPI has that SRS Downmixing bass reduction problem (see here for more details No bass in Fmod ). My concern with Windows Sonic is I don’t know if it colours the sound in any way.

0 Likes

#7

Thanks, I’m looking forward for a fix!

0 Likes