Significant Audio Corruption


We’re using FMOD for our game, but we noticed that occasionally the audio player would corrupt entirely, and all SFX would no longer play properly. In order for the audio to work again, you have to close and restart the game. I’ve linked a video of it happening below:

It stumps us because it can happen at any time, whether after playing a while, or right at the start of a session. There doesn’t seem to be any rhyme or reason to it. We’ve profiled the crap out of it, and all numbers seem normal.

We’re using a bit of an older version FMOD (1.09.03) so I don’t know if this was a known issue that has since been addressed, but if not, and anyone else has encountered something similar, any help would be hugely appreciated.



Hello Kenny,

Could you please check your FMOD Studio project and see how often you are using the Compressor or Convolution Reverb effects? If you have used them in multiple places, such as on individual events & tracks, it can cause some issues similar to this. Try to remove these or move them to a group bus level and let me know if you’re still hearing similar issues.


1 Like

Thanks for the response Richard.

We have 5 compressors and 2 reverbs going on at all times basically. Is that too many? Neither of the reverbs are convolution reverbs, and we have one for sfx, and one for music.

We might be able to reduce it to 3 compressors, but with the way we separated music and SFX with volume control, any less than 3 would lose mix functionality. The profiler also says our CPU usage is within acceptable numbers.

It’s tough to test because we can’t reproduce it on our own (but a number of players are experiencing it), and it doesn’t happen 100% of the time.

Hi Kenny,

Please try with 3 compressors and see if this helps the situation. It also helps to have them at bus level rather than on the events themselves (just to clarify).

Could you also try taking a look into the Stealing behaviour of some of the events in play? If these events are becoming virtual and then suddenly real with the effects on them it might be causing some kind of distortion. Try changing the behaviours from “Virtualize” to “Quietest”.

1 Like

Hi Richard,

We’re not sure we want to open the can of worms with altering stealing behaviour, because we had issues with it months ago and spent a lot of time fine-tuning it. For now we’ll set it to 3 compressors (they’re already on the bus) and see if that helps. If not, then we’ll roll up our sleeves and look back at the virtualization settings.

Thank you for all your help. It’s very much appreciated.