Snapshot Send doesn't seem to work?

fmod 2.01.04, UE 425
I have a return with a verb on it at 0db.
I have a bus with a send at -inf.
Snapshot has the send scoped in, set to 0db while snapshot is engaged
There are several other things in this snapshot - some volume changes and a bus pitch -12 semis.
Everything in the snapshot works and is audible in game except for the verb. The verb is inaudible.
If I remove the send from scope and park it at 0, i hear the verb as expected.
The return is not scoped into the snapshot (in case you’re wondering if that’s being ducked on accident).
Also, I have an intensity automation on the snapshot in the event that triggers it - and am automating intensity over distance. All of that is confirmed working fine, as the rest of the snapshot works great.

I’m stumped. Any ideas?
Thanks!

Thanks for reporting this, I’ve been playing around with it in FMOD Studio and it seems like using a snapshot to change the send level does not work for blending snapshots, but it does work for overriding snapshots. Does that match what you are seeing, or are you having this issue with an overriding snapshot?

It doesn’t seem right to me but I need to consult with some of our in-house experts to be certain this is not expected behavior before declaring it a bug. We’re on a skeleton crew until the new year so I don’t expect I’ll be able to add much before then.

Thanks Derek. Yes. It works for overriding snapshots but not for blending.

We’ve reviewed this internally and confirmed it’s a bug, I’ve added an issue for this to our tracker and it will be fixed in a future release.

Thanks for the update!

I’m afraid we’ve had a miscommunication here about this issue, it turns out that what you’re seeing is actually expected behavior. Sorry for the confusion, I’ve been learning about this today too!

I’ll explain in detail below, but the correct answer is that you cannot change a send level from -inf dB using a blending snapshot. Using an overriding snapshot is the best option if that’s suitable, if you require some kind of blending behavior then you would need to arrange it so the base send level is not -inf dB.

So it turns out that the send level is modelled the same as a volume, which makes sense because a send is basically a fader which routes to another bus. And the way send level works with a blending snapshot is the value in the snapshot is added to the send level when the snapshot is active. This allows multiple blending snapshots to act accumulatively.

E.g. if your send level started at 0dB and you had two blending snapshots which ducked the send level by -3dB, then activating one of the snapshots would duck the send level to -3dB and activating both would duck it to -6dB. Boosting behaves the same way so if you added a third snapshot with a send level of +2dB then activating all of the snapshots would result in the send level being -4dB (0dB base level, -6dB from the first two snapshots, +2dB from the third snapshot).

There is an additional important wrinkle when any of the levels is -inf dB the result is always -inf dB. This includes the base level being -inf dB, which brings us back to your situation. We can use as many blending snapshots as we like to add as much as we want to the send level but if we start at -inf dB we’re going to stay at -inf dB.

Overriding snapshots worked when tested because they directly set the send level to whatever value the snapshot has.

Ah. This makes sense. -inf summed with anything will always be -inf. Since our conversation, I started using overriding for the send, on a new additional snapshot, split out on a different track - and everything is working fine.
Thanks again for your time Derek.

1 Like