Start Offset stops audio relative to end of region within a Transition Region & Loop Region

Hey there friendly neighborhood FMOD peeps,

I’ve got an event that’s behaving unexpectedly.

The transition region works just fine, no issues there. The problem is that when I change the Start Offset (with and without a Random parameter), the audio then stops relatively according to the offset. For example, if the random offset starts the audio file 33% in, the file will stop at 66% until it loops back around, when a different value will be chosen. The only time audio does NOT cut out is when the Start Offset is set to its default value of 0%.

I do need to be able to offset the start because who wants to hear the same exact “PFFT… PFFT… PFFT” every time the player hits the jetpack button again?

Any thoughts? Thank you for your help & time!


EDIT: forgot to mention I’m using FMOD 2.02.05

Try while checking the loop icon button in the bottom tab (properties of the instrument). If it doesn’t work, make it async (and also looped).

1 Like

Just tried that out, but what happens now is that the whole audio file loops irrespective of the loop region, which is not ideal. There’s a short, small bump at the beginning of the file which is the “this jetpack is starting up” sound. My loop region excludes that, but clicking the Loop icon brings that back into audible play.

If I make it both Async and Looped, stopping the sound triggers the GasOff region while still continuing to play the audio under the loop & transition regions.

I suppose I can make a cut so that that front bump is definitely not included as part of that loop sound, though… But then I’m back at square one without the benefits of having a random Start Offset.

Listening to it again while testing, it actually works out ok! The looping file’s Start Offset helps take some of the repetition away from the starting bump.

You’ve done it again, Alci :smiley: Thank you!

But if you want a start offset looping sound, you’ll need a perfect asset. Rebounce it correctly from your DAW, or even simpler: resize the instrument as you want and right-click save the trimmed asset.
I don’t get it: why do you want to start offset while excluding from the loop an attack sound which you’ll never hear at the right place since… the sound starts offset…

I understand the contradiction of what I said :laughing: It doesn’t make sense to me now either. But hey, you led me to a great solution anyway!

Now I only wonder why a start offset would stop audio under those conditions… I can’t be the only person to have a Loop Region & Transition Region in the same event. I’m very curious to understand why audio was cutting out when the event continued playing.

Because the audio asset has finished playing before the end of the loop region (since it started offset). The loop region doesn’t loop the asset, it loops… the region! It’s like setting a loop region bigger than the instrument: the end of the loop has nothing more to play. Looping the asset itself is provided by the icon I just mentioned above.

1 Like