Problem with Start offset/Random Start offset


#1

Hello guys,
I have a problem with the start offset function. I followed the wiking tutorial regarding the torch sound and how to avoid phasing issues. I tried this myself because i am using this in a project right now but it seems, when the start offsets kicks in for example: i have a 10 sec clip, start offset starts at 5 sek, that when it reaches the end of the wav file(not the clip) the remaning 5 seconds is complete scilence. Another person had this too on this forum but he did not get helpful answeres so i am trying it again.
I uploaded an unlisted Video to youtube so you can see for yourself.
Link to the video: https://www.youtube.com/watch?v=4FXGdc8-2mU&feature=youtu.be
Thx,
Jan


#2

Ok, reddit helped me. Did not now that you could set the clip to loop itself.

REDDIT:

“SOLVED: I reached out to FMOD support and they pointed out that there is a loop audio button to the top right of the waveform down on the dock, this has to be highlighted for the audio to continuously loop when start offset is enabled. The button looks like two arrows looping back on eachother.”
Link to original post: https://www.reddit.com/r/GameAudio/comments/64jvsd/need_help_having_an_issue_with_fmod_loop_start/


#3

My loop button is toggled on but still not working. Instead of start radomly in diferents points of the loop it’s fade out randomly. I’m doing the same tutorial and have the last version of FMOD. Thanks


#4

FernanYEA, did you make sure you enabled the loop in the sample itself and not enable the playlist loop? There are two loop buttons that can get confused. One makes the playlist loop, and the other appears when you select a WAV asset in the playlist, and lets you make that wave loop.


#5

Another alternative is to use a “daisy chain” looping playlist. Chop the fire sound, at zero cross, into a large number of short files. Even if two instances happen to trigger the same variation at some points (the more variations you have, the smaller the chance), the phasing will not lastt long if the variations are short.

Granted, it’s a bit hard to author that kind of content. Taking a pleasant sounding fire loop, and chopping it to 128 pieces at zero cross. Maybe there is a useful utility or a Reaper script / action for that…


#6

AH ok! Now i think i selected the right one. But im not sure if this works correctly. When the loop start again doesnt start in other point. Maybe this happens in game? Thank you!


#7

But if the loop finishes, and would then start at a different point, then it would’nt be a seemles loop anymore and you would hear cuts in the audio.


#8

That sound is timeline locked. Enable Async to make it loop and offset freely without timeline sync.


#9

Now Async and loop audio button are activated and this is finally working properly. Thank you very much!!!

This how looks like:
f8e6e0f74ad73eb456abe74879380d5b


#10

I have toggled the async andd the loop button, It work but only the first time, and then it will not begin with offset (like 50%), but from the very beginning(like 0%).


#11

I have toggled the async andd the loop button, It work but only the first time, and then it will not begin with offset (like 50%), but from the very beginning(like 0%).

I haven’t been able to reproduce this issue here. Which version of FMOD Studio are you using?