Sudden issue with 'NullReferenceException' and 'Event retrieval failed' on launching scene

I had this issue a couple of nights ago, and the only way I could figure to fix it was to revert all the work I had done. So I reverted all the changes just to the FMOD project and it fixed the issue. Luckily at the time it was only about 10 minutes work so I wasn’t too bothered, but it has happened again and I can’t just revert this time. The fact that rolling back the changes fixed the issue leads me to believe it’s an issue in the project itself.

I’ve seen other similar threads here, but none seemed to be exactly this issue, or at least didn’t have solutions.

So, everything was working exactly as intended, I was just switching between Unity and FMOD, sometimes in ‘Connect To Game’ mode sometimes not, and then suddenly, without having made any major changes as far as I can tell, I run the game in the editor and I get all these errors:
ie., ‘NullReferenceException’ and ‘Event retrieval failed’

I wondered if it was just sounds being called in Start or Update, but no, if I play the game, anything that calls FMOD throws up the NullReferenceException error.

The two Event Retrieval errors I managed to track down to two Event Emitters in the scene. Disabling these items removed those errors, but not any of the others.

I’ve definitely got an FMOD listener in the scene. I’ve built the FMOD project and refreshed the banks. In SourceTree I reverted the preloadcache.cache and MasterBank files on a whim, but that made no difference. I can audition the events in Unity just fine using the play button in the inspector, with the exception of the two Events causing the ‘Event Retrieval’ error, though they seem to work fine in FMOD.

I’m on 1.06.00, I looked at updating today but I wasn’t sure about the process and it didn’t seem to update properly when I tried, so I just rolled that back until I get some guidance on that.

Any suggestions? I’m completely blocked by this unfortunately :frowning:

I saw in another thread it was mentioned that ditching the #LIVE_UPDATE code fixed a similar sounding problem, but that didn’t work either.

Most of the time these errors are caused by the FMOD system not being able to start up, or not being able to load the banks at level start time. You need to look at the beginning of your log console for the earliest errors.

When you say Log Console, do you mean the Unity log, or the FMOD one?

Because the former is posted in it’s entirety in my first post ( , and the latter displays no errors at all.

Have you defined FMOD_DEBUG?

Hi Nicholas,
I hadn’t defined FMOD_DEBUG, so I’ve done that and captured the logs.
Before I noticed you had replied I emailed FMOD Support directly with a link to the project and Brett has gotten back to me so I’ll pursue this with him via email.


Just wanted to follow up on this in case it’s useful for anyone in future who has made the same mistake as me.

My issue was due to me using the FMOD Gain plugin on an event, but not setting it up correctly in Unity. Docs about that are here: