Switch - getting a lot of distortion during intense scenes

We’re using FMOD 2.00.07 and deploying on multiple platforms but the only one having a problem is the Switch. During normal scenes, everything is fine, but if things get a bit intense the audio will distort. We have tried to adjust our code to ensure less sounds are playing overall, which seemingly limited the intensity of things, but it did not prevent distortions from happening. We have tried Unity 2018.4.15 as well as trying Unity 2019.3.1.

Are there any known Switch distortion issues or other things we could try to work around this issue?

You could try connecting the Studio Profiler and recording a session to get some more information of the performance. See the ‘Switch Specific Starter Guide’ in the docs for information on connecting to the device.

It might also be worth while using a profiler on the game to see if any of the cores are being overused, there is also information on this in the ‘Switch Specific Starter Guide’.

Hi @cameron-fmod. The only Switch Specific stuff I can seem to find is in the API User Manual and it doesn’t offer anything like you’ve mentioned here. I checked through the downloads again and I just don’t see a Switch Specific Starter Guide. That sounds like it would be very helpful. Can you tell me where to find it?

The API user manual that comes with the Switch API download should contain the ‘Switch Specific Starter Guide’, let me know if it does not.

Hi @williamchyr . Do you have any updates on this topic / did you find out what the problem was ? We are also having issues on the Switch Plattform. At some point it seems like the sound thread can’t keep up and then it gets delayed and distorted.
We’re also using FMOD 2.00.07. The Unity version is 2019.2.10f1.

Hi @tlan we eventually found what I think @cameron-fmod was referring to. One of our FMOD API installs didn’t have the mentioned guide but the other did (It may have been included in FMOD switch 2.08 instead of 2.07 - something like that). Inside the doc folder was an FMOD Studio Programmers API for Switch.chm file. In there we found an NX Specific Start Guide that had some stuff for how to initialize FMOD properly and enable the sockets. Once doing that, I was able to connect through an Ethernet port connected to the Switch dock and do some profiling.

All said, it was seemingly just overburdened. The “Update” spike peaked to the top. I think the default for FMOD uses CORE2, but we noticed that Graphics Jobs and Multithreaded rendering seem to also use that thread (diagnosed with the Nintendo CPU tool). So we switched FMOD to CORE1, but it still had the distortion. I kept cutting sounds down and it would help a little each time, but there was still occasional distortion.

What ultimately is working for us currently is that we also lowered the sound quality based on recommendations we found in another thread:
FADPCM is the recommended format.
Vorbis is the second choice, for long streams if FADPCM compression is too low.
Voice count: 32
Sample rate: 24KHz
Speaker mode: Stereo

I’m not willing to say it’s completely fixed, but since those changes and the paring down of sounds in general we have not had audio distortion. Needs further testing still.

1 Like

Okay thank you very much !

I will look into those suggestions !

I will try upgrading to 2.08 and have a look at possible version conflicts.

The overburdance seems a little bit strange to me because I’ve tried Fmod on previous Projects (Fmod Versions lower than 2.00 ), and in my oppinion I’ve had much more sounds going on at the same Time.
But maybe it has something to do with Asset Compression. I’ll have a look at the assets and try reducing the Quality.

Anyway if I find something of interest i’ll keep you updated.