The 3D Object Spatializer does not have a Top Speaker coming out of the Unreal Editor

We’re using Unreal Engine 4 and FMOD to create games with 3D Object Spatializer and 7.1.4 channels.

From one day on the Enable Editor Live Update, the sound placed on the ceiling (top) is not output and is DownMixed.

How can I listen to the ceiling (top) speakers in the Unreal Engine 4 editor??


What version of the FMOD integration are you using?

Unfortunately, using an object spatializer you cannot use Live Update to monitor the output. All the signal after the object spatializer are passed to the system and is no longer controlled by FMOD.

There are a couple of settings to check before you can get 7.1.4 output:

  1. In FMOD Studio Preferences: set the build speaker mode to 7.1
  2. In the event and master bus make sure the speaker mode is set to 7.1.4

  3. In Unreal, FMOD Output Format to 7.1.4 and set the Output Type to a type that supports 7.1.4

With these settings and an object spatializer, you won’t be able to use Live Update to monitor the output but you should be able to hear the ceiling speaker.

Hope this helps!

I’m late to check.
The ceiling speakers are not heard even when Live Update is not turned on.
To be precise, 7.1.4ch in 2D is output from the ceiling speaker and the sound, which is a 3D Object Spatializer, is not output from the ceiling speaker.
Please help. It’s so inconvenient when mixing.

Thank you for the information.

Could you please specify which version of the FMOD integration you are using?

Additionally, are you able to get the correct sound output when building the project, or does the sound never play from the ceiling speakers in both PIE (Play In Editor) and the final build?