Transition timeline fadeout not working(?)

Shouldn’t the audio in the track called “Crickets Extra” fadeout, when the transition timeline has a fadeout for the source? The track keeps playing audio after the fade out has happened. Is this a bug?

Here’s a screen recording:

Thank you :slight_smile:

I’m having another issue where the audio stops is cut off immediately instead of fading out in the transition timeline. Is this a bug as well?

It looks like your first issue (event instrument carries on playing) is because your event instrument might not have the “Cut” property enabled.

Your second issue looks like it’s because the single instrument is not set to async mode, so once the playback cursor leaves its trigger region (to enter the transition timeline) it is no longer playing. Set the instrument to be async and it should fade out as you’re expecting.

Thank you Richard! I thought the trigger region would continue when using the “crossfade function” of the transition region, but I see that is not the case :slight_smile:

It does kind of. If the transition happened whilst the playback cursor was in the middle of the single instrument then it would have kept playing. Because it transitioned at the end of the instrument’s trigger region it became untriggered. You have to imagine that the playback cursor continues along the timeline at the same time as the transition timeline (it’s a bit more complex than that underneath). For transitions it’s usually better to use async instruments just to be safe.

Thanks for clearing that up Richard!

I’m having another timeline transition issue. Sometimes the audio does actually not fade out completely, even though I’m using the fadeout in the timeline transition region. Here’s a screen recording:

Am I doing anything wrong here, if I want the audio to fade out?

This looks to be a bug when you have the transition timeline source instrument (the green one) touching the edge of the destination instrument (the far right see-through handle). To workaround this for now, pull the source instrument back ever-so-slightly until it is no longer overlapping (it will become a single lane size). This will allow the source instrument to fully fade out.

You could also enable “Cut” on the multi instrument which will cause the instrument to untrigger once the playback cursor has exited the transition timeline.

Thank you for bringing this to our attention.

Thanks for the workaround tip Richard :slight_smile:

However, I cannot get the "Cut " function to work either. The instrument stops as soon as it enters the transition timeline, and does not play the fadeout on the “transition timeline source instrument”…

Oh, sorry I forgot to mention that you will need an AHDSR modulator on the volume property of the instrument, otherwise it will just hard stop the instrument when untriggered.

Thanks for taking the time to help me out Richard :slight_smile: