Transition timelines not fading in destination if transition happens at the end of a transition region. Video attached

So I’m having an issue with transition timelines not having the destination fade in if the transition happens at the end of a transition region. I’ve quantized the region to be 1/8th notes, due to the intervals I want the music to transition between, and it works well when the playhead will reach the end of the transition region AND the end of the transition timeline. The only fix is to make the transition timeline be as short as 1/8th, which isn’t optimal because it then becomes a very quick fade.

In the video I change the parameter right at the end to start the transition and show the issue. The second audio track “should” fade in but it doesn’t.

Now I’m sure this is intended behaviour, but my question is just what the workaround here is? I’ve also tried solutions like adding AHDSR to the tracks, or use the Async option, but Async will just mess up a lot of other things.

I found this post, which sounds a lot like the same issue, but I’m not quite sure. If it is indeed then excuse me for making this post.

Thank you.

I haven’t been able to reproduce the behavior shown in your video, which suggests my test event must differ from yours in some respect that isn’t obvious in the video. Are you able to upload a copy of the affected event for us to inspect? And which version of FMOD Studio does the issue occur in?

Thank for the quick reply Joseph.

I’m glad to hear that it might not be intended behaviour. I’m running FMOD Studio 2.00.06, so as of writing, the latest.

I would like to upload the event for you to check out, but not quite sure how I would go about that?

Looking at your video again, I notice that the playback position disappears for a few moments after exiting the transition timeline but before appearing on the main timeline again. This suggests that it is somewhere else during that interval, most likely inside another transition timeline. It’s possible that this second transition timeline is the cause of the behavior you’re seeing, though I’ve no way of knowing for sure without seeing your project.

The easiest way to send us a copy of your project is to package it (by selecting “File > Package Project…” and selecting all relevant components from the dialog) and upload it to an online file sharing service, such as dropbox. If you have purchased a Basic or Premium FMOD license for your game, or if you’re an indie licensee and have purchased access to e-mail support, you could also attach the packaged project to an e-mail and send it to

I see that as well now that you mention it. There are three transition regions, but only one is triggered. Even if I remove the others, it still produces the issue.

Anyway, I’ve uploaded the package here:

I’ve been able to reproduce the strange behavior you describe in the project you uploaded. Curiously, I haven’t been able to reproduce this behavior in any other projects I’ve created, so I suspect the methods I’ve been using to create imitations of your project must differ in some respect to the steps you followed. In any case, it definitely seems like a bug, so I’ve added it to our bug tracker.

Good to hear that it wasn’t just me and this is not intentional. Just hope the cause of the bug shows up soon so it can get squashed. I guess the workaround for now would be to make a new project in the meantime and copy over individual events. Thanks Joseph.

I’m seeing the same issue in my projects as well. It happens with back to back transition timelines, whether in loops, transition markers and transition regions.

Hi FelixSherar,
I had a look at the uploaded project and the video and I think I can help. It looks like you have fade curves on each of the instruments at the end of the loop regions. When the transition is performing the relative jump, the area it is jumping to is fading out due to this fade curve while it is trying to fade in due to the transition.
How you should work around this depends on the purpose of the fade curve on the instrument - for example you could have the instrument longer than the loop and have the fade out happen only outside the loop.
Hope that helps!

Hi Tristanjl,
Apologies for the late response. I’ve tried to remove the fades on the end of the instruments, but the issue still persists. It seems to be happening if the parameter is changing very quickly, while a transition is still happening. So if the playhead is in the 3 Bots transition zone, goes to 0 Bots but then back to 3 bots before the first transition is done. I seems a bit inconsistent, sometimes it works, other times it doesn’t. You can see what I mean if you go to the PoopMusic event (excuse the name, it is a resource in the game) for instance, drag on the parameter back and forward between 0-3 in half second intervals while it is playing. You should notice abrupt cuts if “done correctly”.

But thank you for getting back to me, I’ll be following this thread again!

So I retried the poopmusic event with the fade curves removed and I wasn’t able to reproduce any abrupt cuts. The only thing I noticed was that there is quite a bit of contrast between the end of the loop region and the beginning (as there’s no blend there).
I was wondering if you might be able to get a better result with blended instruments inside the transition timeline? Might be a bit more fiddly (although easier with magnet regions rather than stacked transition regions, but you’ll only be able to have one timeline for each destination rather than configuration per transition).

Here is a video of me messing about, to show you what I’m referring to, should make it easier to understand.

I’m not quite sure what you mean by blended instruments? If you mean that they are too dissimilar loops/samples, that should still not ignore the fades.
I actually did try magnet regions, but exactly due to the fact that they can only have one transition timeline, I couldn’t use it.

Read “blended” as a synonym of “crossfaded” in Tristan’s post.

I’m afraid we can’t view your video. It doesn’t play in the forum, and entering its address into a browser results in a “403 Forbidden” error.

Ah I see. I’m pretty sure I’m crossfading in the transition timeline. Or is @tristanjl referring to separate instruments inside of the transition timeline?

Strange regarding the video, just tried the url in an incognito window and it still seems to work for me? It should work like the previous video I linked to. Is this the link you’re trying?

I see the issue you are talking about now, which I believe is a different issue to the fade curve issue you mentioned earlier. I am able to reproduce it in both 2.00.05 and 2.00.06 but appears fixed in 2.00.07 (which is now available). Let us know if you are still seeing it in 2.00.07.

This is fixed for me in 2.00.07. The transitions are buttery smooth and behaving as expected. Thank you!

1 Like

I’ve waited to reply since I wanted to test if it was also going to work in Unity, but this is taking longer than expected, so will mark this comment as the solution for now.
It for sure fixed the issue in FMOD Studio though, thank you for the help!

1 Like