UE4 build error


(Ilya) #1

I try to build plugin with the following command:
"C:\Program Files\Epic Games\4.8\Engine\Build\BatchFiles\runuat"
BuildPlugin -Plugin=“C:\Program Files\Epic
Games\4.8\Engine\Plugins\FMODStudio\FMODStudio.uplugin”
-Package=“C:\Program Files\Epic Games\FMOD_BUILD” -Rocket -TargetPlatforms=Win32+Win64

And I get this error:
ERROR: Module “FMODStudioOculus” linked into both C:\Program Files\Epic Games\4.8\Engine\Plugins\FMODStudio\Binaries\Win64\UE4Editor-FMODStudioOculus.dll and C:\Program Files\Epic Games\4.8\Engine\Plugins\FMODStudio\Binaries\Win64\UE4Editor-FMODStudioOculus.dll, which creates ambiguous linkage for dependents.

What does it mean?

My platform is Windows 10 x64.


(Geoff Carlton) #2

You’ll need to move the plugin out of the engine directory.


(Ilya) #3

Many Thanks! It’s really helped me!