UE4 MacOS build to iOS fails with "plugin fmodstudio failed to load" on my iPhone


I have fmodstudio installed on UE4 and it’s been working a dream, fine in editor, fine in desktop builds…

However I am currently building for my phone and I keep getting "Plugin ‘fmodstudio’ failed to load because module ‘FMODStudio’ could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project’.

  • I am using Mac OS Big Sur
  • I am not using Remote Build
  • I am using project launcher “Launch > Project Launch”

I have added in Mobile to my build platforms (even though it doesn’t build a mobile folder so thats confusing), I’ve tried to set Desktop as my main track, no luck, I’ve tried including/excluding editor content, no luck. I have “FMOD” as additional non-asset includes, no luck…

Running out of things do try.

Can close this, I’ve no idea what I did to fix it. A new pipeline, fixing the whitelist directory, or upgrading from 4.25 to 4.26, clearing our immediate/cache folders, something must have fixed it. I guess just “clean slate” is a good idea!

Can close this