Unity and fmod integration error CS0102

I’m running Unity 5.5.1f1 and FMOD 2.01.05.
When I import the fmod package(20105) into unity I get this error:

Assets/Plugins/FMOD/src/Runtime/wrapper/fmod.cs(24,29): error CS0102: The type FMOD.VERSION' already contains a definition for dll’

What do I do?

Our minimum supported Unity version is 2017.4 I’m afraid. Can you upgrade to (at least) that version?

Cheers

I can yes, but I am using this version because my lecturer uses it and all the class tutorials are made for it. So unfortunately I can only take part in class with this version.

That’s a shame. Try an old version of FMOD then.

Old topic, but i’ll take a shot… i’m having the same problem with exactly the same error. I’ve tried FMOD 2.01.09 and 2.0.09 both with Unity (v.5.6.7f1) and it still keeps showing me that error FMOD.VERSION' already contains a definition for dll’… I’ve tried different versions of Unity as well, but didn’t help. Any ideas how i can solve this problem?

Our minimum supported Unity version for FMOD 2.00.xx and 2.01.xx is 2017.4. You’ll need to use Unity 2017.4 or newer.