Unity Debug Overlay hide problem

Hello. I have some issues.
Unity 2021.1.5 Fmod plugin 2.01.09
Debug Overlay still visible in Editor if I choose development build only and development build settings are off.

Does the same happen if you select the “Default” platform and change the Debug Overlay setting there?

Yes. It happens with Disabled and Development Build Only options in the Default platform too.
Debug overlay still visible.

I’ve not been able to replicate this on our end. I’ve tried using Unity 2019.4 and 2020.2 and FMOD 2.01 and FMOD 2.02.

I using Unity 2021.1.5 and FMOD plugin 2.01.09

I reproduced the issue by creating a new project and added a plugin. Unity 2021.1.6f1 Fmod plugin 2.01.09
Here project google drive link FmodDebugOverlay.zip - Google Drive

If you click Editor Play in Sample Scene you will see debug overlay but in settings selected option Development Build Only and Development Build checker is off in Player Settings.

Expected Result: debug window is hidden in editor

Can I confirm that you have an actual FMOD Studio event instance created and playing?

I didn’t fully understand your question, but yes, Fmod Unity Instances are playing. The problem only with Overlay.