Editor Debug Overlay Keeps Reverting Back to Enabled

The “Editor > Debug Overlay” settings keeps reverting back to Enable. Steps to reproduce:

  1. FMOD > Edit Settings > Platform Specific > Editor > Debug Overlay > Set to Disable
  2. Close Unity
  3. Open Unity
  4. Debug Overlay is back to Enable

Version: 2.01.11
Unity 2021.3 LTS

It sounds like the FMOD settings script is not being written to correctly. Can you confirm if your project is source controlled? You might need to adjust your settings to either allow writing to this setting or to check it out whilst you’re using Unity.