(Unity) DllNotFoundException: fmodstudioL when calling FMOD.Memory.GetStats

I’ve never seen this error in the editor before, but I ran into it when making a build. The error message appears as soon as the game is launched.

DllNotFoundException: fmodstudioL
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced, System.Boolean blocking) (at C:/gamedev/unity/monospaced-lovers/Assets/Plugins/FMOD/src/Runtime/wrapper/fmod.cs:890)
FMODUnity.RuntimeUtils.EnforceLibraryOrder () (at C:/gamedev/unity/monospaced-lovers/Assets/Plugins/FMOD/src/Runtime/RuntimeUtils.cs:365)
FMODUnity.StudioListener.OnEnable () (at C:/gamedev/unity/monospaced-lovers/Assets/Plugins/FMOD/src/Runtime/StudioListener.cs:17)

My situation is pretty much the same as these two threads:

So I guess it’s a common problem, but I don’t know about the solution. I confirmed that fmodstudioL.dll is located under Assets/Plugins/FMOD/lib/win/x86_64 in my Unity project, and Plugins/x86_64 in the data folder in the Windows build.

Any help would be appreciated - thanks.

One thing to check is the platform settings for each dll:

  • Select “Assets/Plugins/FMOD/lib/win/x86_64/fmodstudioL.dll” in Unity

  • Make sure it looks like this in the inspector

  • Also make sure that “Assets/Plugins/FMOD/lib/win/x86/fmodstudioL.dll” is only ticked for x86

Other than that, try reinstalling the FMOD Unity Integration. If it’s still not working, please provide your FMOD and Unity versions, and which platform you are building too, and I will take a closer look!

1 Like

Thank you. The DLL import settings were incorrect in my project, so I changed them based on your instructions and it works now.