Unity html5 - performance issues and studio settings


i just changed the audio in my project from inbuilt unity html5 audio to fmod - it builds fine but the performance is pretty bad - lots of pops and audio dropouts as well as some quite impressive stutters at times. turning off the unity audio helps but the problem still makes it unusable. i am not doing anything much just playing a couple of events concurrently and a bit of volume panning using the ahdr and also directly from script.

I wanted to tweak the fmod html5 settings but i can’t seem to get them show up in settings or in studio - desktop seems to be the default platform in studio and there is no option to add html5 as a platform

have i missesd something and does anyone have any general tips for performance on html5 other than what is in the documentation



If you are just building Desktop banks for Unity’s web builds, you have to understand HTML5 is seriously limited. Try running FMOD events with nothing happening in the background first, then introduce disk loading, gameplay, and make sure that the FMOD update is getting called enough.

There isn’t a dedicated “HTML5” platform, but you can have a Desktop platform and rename it HTML5. This is how we did it in the Examples project and set that platform to stereo.

The main thing to improve between update stuttering is to modify runtimemanager.cs and before the system init insert result = coreSystem.setDSPBufferSize(2048, 2); or try result = coreSystem.setDSPBufferSize(2048, 4); if that doesn’t help.