Unity Initial Parameter change not fully functioning.


I’ve got two parameters set up in fmod to change from normal state to boss music and to trigger a “second level”

Boss music fades out normal music and triggers then fades in the boss music.

Second level moves first’s events into a silent loop and second level’s out of the silent loop.

So, the problem is this:

While the boss music is triggered and fades in fine, the normal music doesn’t fade out and while the second level’s music starts, it plays the first level’s music underneath and continues as if it’s the first level :frowning:

It works fine in fmod, works fine in a debugged mode but doesn’t work with the initial parameters set in unity.

Any suggestions would be greatly appreciated.

Can elaborate on the situation if i’m being to vague.


The FMOD Studio Event Emitter script will create a new event, set the initial parameters and start it using the conditions specified.

Using a second Event Emitter Script will create a whole new event that doesn’t know about the first one.

There is another script, FMOD Studio Parameter Trigger, that uses an already existing event (created by an Event Emitter or your own script) and can change parameters using conditions.

Otherwise you can always create your own scripts to create and customize events according to your game. There is a lot of good information on our website:

1 Like

Thanks for the swift answer!

I failed to mention that we’re already using the FMOD Studio Event Emitter script. That’s what I was using to adjust the parameters and yet only some of the volumes in FMOD are changed.

Boss one is a simple fade in boss music and fade out several audio tracks. The boss music fades in fine but none of the audio tracks fade out.

Again, it works fine in FMOD but when setting things up in the Studio Event Emitter, it fails to read all the information for some reason.

We set up a debugged mode so we can change the parameters IN GAME and it worked fine.

As far as I can tell, it’s the studio event emitter that isn’t working correctly. Or more likely, i’m not using correctly.

Thanks again for your answer and apologies i wasn’t more clear before.