Unity webgl production libary issue

Looks like FMOD midi playback doesn’t work on Unity Webgl.
It return FMOD.RESULT.ERR_FORMAT when create sound.
The issue only exists on production build. if I build and run the development build, everything is working well. Could you check if midi codec has been removed on FMOD production build for unity webgl?

I can confirm that MIDI is excluded by the reduced version of the Core API, and I can further confirm that the release version of the Studio API uses the reduced version of the Core API. For a full list of what is removed from the reduced version, see the getting started docs.

I simple work around for Unity might be to delete libfmodstudiounityplugin.bc and duplicate libfmodstudiounitypluginL.bc, renaming it to libfmodstudiounityplugin.bc. This means the logging version of FMOD will be used in both Development builds and release builds but you will get all the functionality you need. You can use the settings to control the logging output to avoid that during release if you choose.

1 Like

Thanks. It works. :+1:

Hi, thanks for your reply, it helped me! :relaxed: