Unreal 4.8.1 is not packaging the new FMOD 4.8 plugin for content-only projects

My team and I are trying to push a build of the game we are working on out to the Play Store for testing. Sadly, whenever we launch or build the game we are still getting the following error:

“Plugin FMODStudio failed to load because module FMODStudioOculus could not be found. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.”

I thought maybe it was just an issue with our project. So I made a new one based on a template from 4.8. I changed absolutely nothing in the template, hit launch to my android device and it still showed the above error.

Some extra details:
I am working in Unreal Engine 4.8.1
FMOD is located in Engine/Plugins
The project i’m testing in has no reference to FMOD at all, but because it is in the engine it is still looking for it upon packaging.

Any help would be greatly appreciated.

Unfortunately plugin support for Android still doesn’t work “out of the box” for 4.8, and we were too hasty in removing the workaround section in the deployment docs.

For now the only workaround is to modify the engine, same as the steps given in 4.7, mentioned here:

So we are still waiting for support for plugins with dynamic libraries on that platform.

I am currently trying to deploy for android, and i can’t find the function “CopyPluginLibs” in “UEDeployAndroid.cs”

Is this process not necessary anyone for 4.10? I tried to deploy on my android phone but the application doesn’t launch. I deployed for windows 8 desktop and the program works.

Make sure you get from the 4.10 branch in github. The code has changed slightly in the latest branch.