Unreal can't find plugin in 5.4

I am trying to update a project to Unreal 5.4.1 but it can’t find the plugin. I am getting the error in the screenshot. This is using the binaries version of Unreal from the Epic Game Store. I tried putting the plugin in the \UE_5.4\Engine\Plugins\Marketplace and \UE_5.4\Engine\Plugins\ folder but both give the same error. I am using the 2.02.22 plugin for UE5.4 for Windows. I get this error when just trying to open the editor, not even trying to open any projects.

I am trying to avoid putting the plugin into the folder’s plugin folders because it’s an easier workflow, as I don’t have to include the plugins folder into the repo.

Hi,

Just to clarify, what version of Unreal and/or the FMOD for Unreal plugin were you using prior to updating? What directory was the FMOD plugin previously located?

Previous version is Unreal 5.2.1 with FMOD 2.02.15.
Directory is \UE_5.2\Engine\Plugins\Marketplace\FMODStudio.

By the way, ever since Unreal 5.0, the binaries version of Unreal doesn’t recognize FMOD if it’s in the \Plugins\ folder. If it’s moved to \Plugins\Marketplace\ it works fine. I posted this to the forums a long time ago. The source version doesn’t have this problem, if it’s \Plugins\ it detects it and compiles it fine with the rest of the engine.

Unreal 5.4.1 with FMOD 2.02.22 works fine with the binaries version if I put it in the Projects\Plugins\ folder. But I don’t want to do that, much easier workflow for the team and less compile time for the programmers. Which is why I have my team place it in the Engine\Plugins\Marketplace folder previously.

Same problem for me, but i’m trying to put it in the project plugins folder !

There is a known issue with UE 5.4 where the plugin is built for the incorrect UE version, which may be causing the issue you’re describing. As a workaround, I would recommend placing the plugin in the ./Projects/Plugins/ folder, recompiling the project from your IDE, and then moving the plugins to the ./Engine/Plugins/Marketplace folder and seeing whether that resolves the issue.

What is the exact error message that you run into when trying to do this? Is your project a Blueprint only project, or is it a C++ project?

That got it working in Windows. Thank you very much.

Unfortunately it’s not working in Linux. I downloaded the Linux version of the 5.4 plugin. Using the source version of Unreal 5.4.1 with FMOD 2.02.22, it gives a bunch of errors while compiling FMOD. I built the engine without FMOD and tried the same workaround of building it in the project folder, but it gives the same compile errors.

Also it causes the PS5 version to not compile in Development or Shipping. It gives the following compiler error:

static assertion failed due to requirement ‘bFmtStrErr<UE::Core::Private::FormatStringSan::TAtArgPos<0>>’: ‘%l’ expects integral arg (eg. char, int, long, etc.) Project C:\Unreal\Engine\Source\Runtime\Core\Public\String\FormatStringSan.h 112

These are the steps to replicate:

  1. Download and unzip Unreal Engine 5.4.1 (changelist 33305029) from Unreal’s github.
  2. Download and unzip PS5-5.4-33305029.zip from your Organization Portal into the Unreal Engine 5.4.1 folder.
  3. Run Setup, GenerateProjectFiles, then build the Engine.
  4. Launch the engine. Create a First Person C++ starter project.
  5. Build the starter project for Development Editor Win64. It should compile fine.
  6. Build the starter project for Development or Shipping PS5 and it’ll give the compile error.
  7. Alternatively, launch the project in the Unreal Editor. Open the Project Launcher and try to launch the starter project on PS5, and it’ll give the same compile error.

Without FMOD, everything will compile fine. With the FMOD plugin. It’ll give the compile error above.

1 Like