Unreal fails to load FMOD banks

Unreal version: 4.19
Fmod version: 1.10.05

I used the “Load Bank” Blueprint node and selected my bank in the list, but when i run it i get this error in the log:

LogFMOD: Error: f:\jk\workspace\1.10_UE4.19_Win64\studio_api\src\fmod_bankmodel.cpp(163) - Failed to open file ‘…/…/…/…/…/…/Users/carl_/Documents/Unreal Projects/Carl_Project_C/Content/FMOD/Desktop/The_Bank.bank’
LogFMOD: Error: Failed to load bank The_Bank: File not found.

I’m trying to unload my bank and then load it again to reset everything when i change levels in the game. (is it a good solution?)
The unloading part works well, i select my bank in the list and all the sounds stops. But i can’t load it again. Even without unloading first, the load bank function still gives me this error.

Do anyone know what could cause this?
I did this exact same thing in a previous game using unreal 4.16 and that time it worked. Only difference is that this is a C++ project and the previous was Blueprint only.

I also tried this now in a completely new project with the same result

I found the problem!
Apparently you can’t have underscore or spaces in the bank names.
I guess this is a bug?

Underscores should work fine in bank names. But there does appear to be a bug in the integration regarding spaces. UAssets cannot have spaces in the names, so when we create them for banks, events, etc. we replace spaces with underscores. Then when using LoadBank we use the name of the UAsset passed in, which now has underscores instead of spaces. I will create a task to fix this but for now your best option may be to rename the banks in Studio to use underscores instead of space.

Just in case this is to do with the Master Bank, in the UE4 FMOD Settings, a string needs to be specified for the name of the master bank, by default this is “Master Bank”. If you change the name of the bank then this needs to be updated also.

Currently the default is always set to “Master Bank” in UE4, I will create a task to make this use the name of the master bank in Studio when you validate FMOD (in UE4).