Unreal's Editor crashes while connecting to live update

My editor crashes if I try to connect to live update in fmod. Sometimes it succeeds but crashes if I try to run the profilier. It worked before I updated to 2.1 from 2.00.07.

Current FMOD version: 2.1.04
Current Unreal version: 4.24.3

There is nothing in the logs.

Thanks for reporting this.

I’ve tried testing the issue using UE4 4.24.3 with FMOD Studio 2.01.04 and FMOD 2.01.04 for UE4 4.24 on Windows, but was unable to reproduce a crash either from connecting or from running the profiler while connected. I tested connecting to both the UE4 editor and to a UE4 play in editor session and recording profiler sessions several times.

To help further can I get a couple of things from you please:

  1. Could you try to reproduce the issue and then grab the runtime logs from the FMOD Studio side.

If you open the Console window in FMOD Studio (“Window” menu, “Console”), switch to the “Logging” tab and then choose “Runtime” and enable “Show verbose logging” before attempting to connect live update you should see the relevant log messages:

Please copy the messages from the console window and paste them into a reply here.

  1. You mentioned that you have updated from 2.00.07 to 2.1, did you update both FMOD Studio and the FMOD UE4 integration to 2.01.04?

2020-09-22-19-23-47_log.txt (1000.1 KB) Fmod studio freezes when launching the profilier, but here is the crashlog.

  1. I have updated both Studio and UE integration.

So when you try to connect FMOD Studio to UE4 using live update the UE4 editor usually crashes but in this instance FMOD Studio crashed? Or have I misunderstood and it’s always FMOD Studio which crashes?

Looking at the log from the crash it appears that there may be something specific about your FMOD Studio project triggering this crash, would you be able to share your complete project with us for further analysis? You can use the “Package Project…” command in the FMOD Studio “File” menu to create a package which you can upload to your profile page at https://fmod.com/profile#uploads.

I also noticed that the crash occurred after the live update connection was established and either during or immediately after the initial sync. As an experiment you could try disabling the initial sync. Open the Preferences window in FMOD Studio (“Edit” menu, “Preferences…” command), switch to the “Interface” tab and uncheck “Synchronize changes upon connecting to game”:

Finally close the Preferences window and try connecting live update. It’s probably not a useful long term workaround but it might help you get unstuck while we work on figuring out this issue.

The new update(2.1.05) fixed the problem.

That’s good to hear, thanks for letting us know. To be honest it’s not clear to me why upgrading to 2.01.05 would have any impact on connecting or profiling with live update, so if the issue reappears please let us know and we’ll dig into it further.