Using UMG slider to control FMOD Parameters

I’m having some trouble getting my sliders to control the parameters of an FMOD component. I am in the process of creating a simulated mixing desk, and hope to be able to control various aspects of an FMOD multitrack including volume level.

I have created the mixer in UMG, then attached it to an actor so that the user can zoom in/out and move relative to it (called Mixer3d). I have also attached my camera to a pawn for this purpose (called RTSCam).


I have a separate UMG which overlays the screen which provides a play/stop function. I found that if I attached my FMOD component to the RTSCam, then casted to it from the UMG blueprint I could access the play and stop functions of FMOD:


I ran into some trouble when I tried a similar approach with my sliders. It works when I use ‘Set Volume’

Set Volume

But not when I use ‘Set Parameter’

Set Parameter

Here’s the FMOD session:


Apologies if this seems rudimentary, I’m fairly new to both Unreal and FMOD. I would like to use the set parameter function as I have other things to control such as panning and routing.

Thanks in advance!


We’re having the same problem when trying to set an FMOD parameter with certain one shot sounds. We have confirmed the value being sent to FMOD “Set Parameter” within the blueprint is correct (using an onscreen Print String), but we’re only getting the default sounds playing back, and the FMOD Profiler shows us that its not receiving anything other then 0 for the parameter value when the event plays. Is there some sort of timing issue in FMOD between firing the event and receiving the parameter value?

If you run the profiler, as Jesse did, you can see if the parameter is getting to the instance or not. If you record a profiler session, you can look at the capture API file (either in the tool, or by finding the profiler directory on disk).

You should see the call to set parameter by name in the capture API file, since it records all commands sent to Studio. If you find in the capture file that the command is being sent but it doesn’t seem to be having an effect, you can contact with the capture and banks, and we can see what is going on.