XboxOne error :" Initialization failed : FMOD.Studio.System.create : ERR_INTERNAL"

Hi there, I hope this is not the wrong place to post my problem.

I have an issue with fmod on Xbox that doesn’t appear in our pc or switch builds and it’s going to make me crazy!

SystemNotInitializedException: [FMOD] Initialization failed : FMOD.Studio.System.create : ERR_INTERNAL : An error occurred that wasn’t supposed to. Contact support.
at FMODUnity.RuntimeManager.CheckInitResult (FMOD.RESULT result, System.String cause) [0x00000] in <00000000000000000000000000000000>:0
at FMODUnity.RuntimeManager.Initialize () [0x00000] in <00000000000000000000000000000000>:0
at FMODUnity.RuntimeManager.get_Instance () [0x00000] in <00000000000000000000000000000000>:0
at FMODUnit
RuntimeManager.get_StudioSystem () [0x00000] in <00000000000000000000000000000000>:0
at FMODUnity.RuntimeManager.AddListener (FMODUnity.StudioListener listener) [0x00000] in <00000000000000000000000000000000>:0
at FMODUnity.StudioListener.OnEnable () [0x00000] in <00000000000000000000000000000000>:0

I have already Disabled Unity audio and here is my fmod Settings :


In Fmod studio, I have correctly builded xbox bank and desktop banks.

Did I miss something?? I have to make a version verry soon so I really need your help!

thanks you all for your help!
-Mathew

Hi Mathew,

Have you included all the Xbox libs needed as described in the Platform Details section of the FMOD Studio Xbox One API you installed?

Hi Richard,
I have included fmodL, fmodstudioL and resonance audio. I also enable the “Load on startup” for fmodL and fmodstudioL .

For the xbox part, every single part has been included in the project so I think that there is no mistake possible.

Hi again, in case someone else experiment the same issue, you have to disable unity audio and check if it’s correctly setted to false by opening the setting with your notepad.

Hope it’ll help someone