Async Instrument stop loop

I mean you said you made an attempt by putting the environment instrument in a parameter sheet. This should work.
As I said, the loop problem comes from the fact your transitions contains transition timelines.

Yes, but the instrument stopping anyway :frowning:

So you messed up with something. Of course, you should check the “loop” button on the instrument. Could you share a screenshot of your parameter sheet, with the instrument’s details?

Could you guide me how to do that?

Just open the parameter sheet, click on the instrument, which will show it’s details in the bottom tab.

like this?

Hum… You said:

but you don’t seem to know what parameter sheets are…
Check the doc about that. I’ll help you later when I go to my PC.

In the project I use 2 discrete parameters: one is to switch between the different sections “Secciones”(Soundscape - Combat - Boss), and the second is to activate different tracks within the “Combat” section, to add more tension: “grados de tensión” (My lenguage its spanish)

Oh, sorry. Its because i deleted that. Get me a second and i do this again

1 Like

this?

Yes. The multi (2d track) maybe should stay in the timeline, from what I see in your first screenshot, depending on the behavior you want. Don’t forget also to remove the single instrument (1st track) from the timeline. You also should check the “cut” button and set a release on the instrument volume’s AHDSR, depending if you want the single instrument to restart at the beginning or not when it is untriggered/retriggered.
So? Doesn’t it loop correctly when switching from section to section?

I need the “ambient” track to be extended until the second section including “combat”. When changing section (Soundscape - Combat - Boss), everything works ok, until the track ends and is NOT repeated. Now I will send you several screenshots so you can see it.

Starting

I’d also like to see the content of the “trigger behavior”.

of that instrument? or region?

The instrument (I can see it’s not empty).

I you stay still on section 0, does the loop problem still occurs?
Since your instrument is long, try this to test the loop more easily (it will start near the end of the asset):
image

I think I see what’s happening here. It’s the combination of two things:

  • When an asynchronous instrument whose loop instrument mode is toggled on and whose play count is infinite is untriggered, it finishes playing out the sound file it’s currently playing, then stops.
  • When you attempt to trigger an instrument whose polyphony is set to one and whose stealing mode is “none,” and there is already an instance of that instrument playing, the instrument won’t start playing.

You have constructed an event in which the instrument will inevitably stop if it is untriggered, and will not start again if it is retriggered while it is playing out its sound file after being untriggered.

The easiest way to fix this is to ensure the instrument is never untriggered. For example, starting from the version of the event in your first screenshot, try dragging the right edge of the “ENVIRONMENT” instrument to the right of the right edge of the “BOSS” loop region, such that the instrument extends over the full length of the timeline that you’re using.

Alternatively, ensure that the instrument always stops immediately when untriggered. To do this, click on the instrument’s “Cut” button to toggle it on.

Hum, @joseph I think you are wrong. He can’t ensure that the instrument is never untriggered, because of the loss of continuity of async instruments passing through transition timelines. It WILL be untriggered when passing through one of those transition timelines, no matter the settings. That’s why I suggested another solution, for that instrument to never be untriggered, by putting it in the parameter sheet.

But maybe is this transition timeline a bug and should be fixed? I supposed it rather was a technical and unavoidable issue…

By the way… he needs those problematic transition timelines because he needs to automate the volume while transitioning, and which wouldn’t be necessary anymore if he had that option. I think that counts as another +1 :smiley:

Oh, drat, you’re right.

In that case, putting the instrument on a parameter sheet instead of the timeline should resolve the issue - as long as the instrument is never untriggered.

It is a complex issue. While we present a transition timeline as a special extra timeline that the playback position moves through, under-the-hood there’s actually three different playback positions involved every time an event goes through a transition timeline - and as you can imagine, this can make it tricky to determine whether an instrument has actually been untriggered or not.

You’re right. I’ll add another +1 to the list.