Audio table can't find files with special characters

I have many dialogue files with special characters. Example:

FMOD’s audio tables is not picking them up for some reason. Is anyone else experiencing this issue?


I’m having trouble reproducing this issue. I added a file of that name to an audio table in the example project.

Could you provide a screenshot or a list of reproduction steps so that we can replicate the issue?

Actually, I’ve just had a startling revelation. If I duplicate any of these “invisible” files, they suddenly become visible. If I copy them with the command line, they remain invisible. If I open the file’s name to edit it, with the finder, then make no changes, and stop editing, it suddenly becomes visible too.

These files are being produced with the “say” command:
say "hello" -o "$tag"
ffmpeg -i "$tag.wav" "${f%.aiff}.wav"

where $tag == “356_François_LeMoon_5”

I’m not sure what’s going on, but it’s perfectly reproducible.

When I test here, file names containing the “ç” character display and can be auditioned in audio tables. I must therefore be doing something different to you. Could you explain how this issue manifests in more detail? For example, which version of FMOD Studio are you using? Which characters seem to be causing the problem? And how does the audio files not being picked up by FMOD Studio manifest?

Thanks for your reply!
So now I’m not certain it’s the special character. I’m not 100% sure what’s happening, but thankfully it’s 100% reproducible.

I’m on MacOS Catalina using Unity 2019.4.18f1. Here’s how I create the file:
say “hello” -o “356_François_LeMoon_5”
ffmpeg -i “356_François_LeMoon_5.aiff” “${f%.aiff}.wav”

Provided you don’t alter the generated wav file by trying to rename or duplicate it with the Finder build into MacOS, the resulting file should be invisible to the Audio Table scanner. I’m using a Localized audio table with the locale set to “us-en.”

Let me know if that all makes sense. I’ve been able to reproduce it, but like I said, if I try to rename the file, don’t make any changes to it, and then close the filename edit bubble, suddenly the file becomes visible.

Testing here, I’m afraid I’m still not able to reproduce this issue. When I view the audio table while creating files in terminal using the method you describe, the files appear normally.

Are there any other applications that use the folder in which you’re creating files? It is synchronized to DropBox, for example?

Does exiting FMOD Studio and re-loading the project cause the missing files to appear?

Hey thanks again for taking a look. The only way I can make this reproduce is by using one of my generated files. I was about to share a zip of a bunch of them, but zipping and unzipping them seems to make them “visible” to FMOD.

I just tried a single file upload/download to/from google drive and that same file remained invisible. So here’s that file.

Any luck with this?

We were able to reproduce the issue using the file you provided us with.

Unfortunately, our testing has not yet revealed why this file is different to other files we create, and thus why this issue is occurring. We suspect it must be some feature of the ffmpeg command you’re using, as it does not appear to be a standard terminal command. Are you able to check your .bash_profile file to determine exactly what this command does?

Oh gotcha. Huh, very strange… ffmpeg is a media library used for processing video and audio. It’s forms the basis for VLC player’s functionality (among other software). I was using it to convert aiff to wav.

I’ve done several tests with ffmpeg. I used commands both similar to and identical to those you quoted, and a variety of filenames both with and without the “ç” character. In all cases, the resultant files appeared correctly in FMOD Studio’s audio tables.

I must be doing something differently to you. Do you know which specific version of ffmpeg you’re using?

Oh weird! So I’m using ffmpeg version 4.3.1 and I’m on MacOS 10.15.7.
If I can provide any other files/information, just let me know.

Hi VoodooDetective,

It appears that this is a Qt issue - [QTBUG-70732] QDir::entryList hides file names with unexpected normalisation on macOS - Qt Bug Tracker - that has been fixed 5.12.5, while FMOD uses 5.12.3. We only change Qt versions on major versions, and we have one ready for our next major release, so it will be fixed for 2.03.00.

Oh awesome! Thanks for letting me know!